summaryrefslogtreecommitdiff
path: root/dev-python/python-report/python-report-0.23.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-10-27 18:38:05 +0200
commit24934e623441310f644e5f72855b0f2bf9f3cd1a (patch)
treea453939bf58199bc2c3ff27bcf0accf2b221c6c4 /dev-python/python-report/python-report-0.23.ebuild
parent687f45092b4f4ccf33765cee7427f054bae22344 (diff)
Incoming! Moving Rogento.git to kogaion-desktop. Finally
Diffstat (limited to 'dev-python/python-report/python-report-0.23.ebuild')
-rw-r--r--dev-python/python-report/python-report-0.23.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-report/python-report-0.23.ebuild b/dev-python/python-report/python-report-0.23.ebuild
new file mode 100644
index 00000000..537701dd
--- /dev/null
+++ b/dev-python/python-report/python-report-0.23.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.fedorahosted.org/report.git"
+EGIT_COMMIT="${PV}"
+inherit git-2 autotools eutils
+
+DESCRIPTION="Provides a single configurable problem/bug/issue reporting API."
+HOMEPAGE="http://git.fedoraproject.org/git/?p=report.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/rpm
+ net-misc/curl"
+RDEPEND="dev-libs/openssl
+ net-misc/curl
+ dev-libs/libxml2
+ >=app-misc/rogentos-version-1"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-sabayon-config.patch
+ epatch "${FILESDIR}"/${P}-disable-rpm.patch
+ epatch "${FILESDIR}"/${P}-disable-Werror.patch
+
+ eautoreconf || die "cannot run eautoreconf"
+}
+
+src_configure() {
+ econf --prefix=/usr || die "configure failed"
+
+ # Create some kind of version file to suit the build system
+ mkdir -p "${S}"/python/report/plugins/RHEL-bugzilla/bugzillaCopy || die
+ touch "${S}"/python/report/plugins/RHEL-bugzilla/bugzillaCopy/VERSION || die
+}
+
+src_install() {
+ default
+ # remove Red Hat stuff
+ rm -rf "${D}"/python/report/plugins/{strata,RHEL-bugzilla} || die
+}