summaryrefslogtreecommitdiff
path: root/app-text/simplenote/simplenote-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:53:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:53:16 +0100
commit856a1c859d409252aabaf7c4f6fe05a48635b50d (patch)
treea2915082a4597ff81a40160af258f4585c761c44 /app-text/simplenote/simplenote-1.5.0.ebuild
parent6ea0ea9f6e73cc04d42ff0d7fb039aff1a712bf0 (diff)
app-text/simplenote : version bump
Diffstat (limited to 'app-text/simplenote/simplenote-1.5.0.ebuild')
-rw-r--r--app-text/simplenote/simplenote-1.5.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/simplenote/simplenote-1.5.0.ebuild b/app-text/simplenote/simplenote-1.5.0.ebuild
new file mode 100644
index 00000000..0651e6f0
--- /dev/null
+++ b/app-text/simplenote/simplenote-1.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils unpacker
+
+DESCRIPTION="The simplest way to keep notes"
+HOMEPAGE="https://github.com/Automattic/simplenote-electron"
+SRC_URI="https://github.com/Automattic/simplenote-electron/releases/download/v${PV}/Simplenote-linux-${PV}-amd64.deb"
+
+LICENSE="GPL2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/nss
+ media-libs/alsa-lib
+ x11-libs/gtk+:2
+ x11-libs/libXtst
+ x11-libs/libnotify"
+RDEPEND="${DEPEND}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ mv * "${D}" || die
+}