summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 20:50:02 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 20:50:02 +0100
commitf6904b46546571858876b98f8c2e801a8edf61a6 (patch)
treebbb8eb500a318aac8a2e503622cf426bb48cfede /app-portage
parenta74f62c3ee3188193217ea00bd20129d3a549c10 (diff)
app-portage/sisyphus : version bump
* reduce the number of connections to the database to speed things a bit * implement own binary fetcher mechanism, written in pure python * bypass portage's broken binary fetcher mechanism * once again show package revisions in database (regression introduced in 1.1805) * make sure we leave no zombie processes alive * restrict to binary mode only for greater reliability and stability
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/Manifest1
-rw-r--r--app-portage/sisyphus/files/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch13
-rw-r--r--app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch24
-rw-r--r--app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch82
-rw-r--r--app-portage/sisyphus/sisyphus-1.1809.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1805-r9.ebuild)24
5 files changed, 13 insertions, 131 deletions
diff --git a/app-portage/sisyphus/Manifest b/app-portage/sisyphus/Manifest
deleted file mode 100644
index 48a0ff14..00000000
--- a/app-portage/sisyphus/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST sisyphus-1.1805.tar.gz 209422 BLAKE2B 68cbb96f1fbadf4864a08540efdfc4edfc1a0045c666ce7e6304e771578e019052be5780679d75113f6770e2f35cd910452ed769b454fce64595a9246839be2c SHA512 1bb7e1c66aa7851573165b8491a382dc4e7b2a42bbb3bf7b44c5472e8f97093d2dc473d56a163ace18f5154f53b07944235a8f80dac1d7cd6b9db144ecbba2be
diff --git a/app-portage/sisyphus/files/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch b/app-portage/sisyphus/files/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch
deleted file mode 100644
index 7bc66024..00000000
--- a/app-portage/sisyphus/files/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/helpers/make_local_csv b/src/helpers/make_local_csv
-index 91e00bb..50e704b 100755
---- a/src/helpers/make_local_csv
-+++ b/src/helpers/make_local_csv
-@@ -1,7 +1,7 @@
- #!/usr/bin/env bash
-
- makecsv() {
-- qlist -ICScv|sed -e "s/\//\,/" -e "s/[\t ]/\,/" -e "s/\:/\,/" >> /tmp/localPackagesPre.csv
-+ qlist -ICSv|sed -e "s/\//\,/" -e "s/[\t ]/\,/" -e "s/\:/\,/" -re "s/-([0-9])/,\1/" >> /tmp/localPackagesPre.csv
- mv /tmp/localPackagesPre.csv /var/lib/sisyphus/csv/
- }
-
diff --git a/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch b/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch
deleted file mode 100644
index b817acbc..00000000
--- a/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
-index 1d05b8c..1f15140 100755
---- a/src/backend/libsisyphus.py
-+++ b/src/backend/libsisyphus.py
-@@ -28,7 +28,6 @@ def checkRoot():
-
- def checkSystemMode():
- portage_binmode_make_conf = '/opt/redcore-build/conf/intel/portage/make.conf.amd64-binmode'
-- portage_mixedmode_make_conf = '/opt/redcore-build/conf/intel/portage/make.conf.amd64-mixedmode'
- portage_make_conf_symlink = '/etc/portage/make.conf'
-
- if not os.path.islink(portage_make_conf_symlink):
-@@ -37,10 +36,8 @@ def checkSystemMode():
- else:
- if os.path.realpath(portage_make_conf_symlink) == portage_binmode_make_conf:
- pass
-- elif os.path.realpath(portage_make_conf_symlink) == portage_mixedmode_make_conf:
-- pass
- else:
-- print("\nThe system is not set to binmode or mixedmode, refusing to run!\n")
-+ print("\nThe system is not set to binmode, refusing to run!\n")
- sys.exit(1)
-
- # get current mirror information, so we know where we download from (CLI + GUI frontend)
diff --git a/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch b/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
deleted file mode 100644
index 55af7a86..00000000
--- a/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
-index ac7d7b2..1d05b8c 100755
---- a/src/backend/libsisyphus.py
-+++ b/src/backend/libsisyphus.py
-@@ -192,28 +192,28 @@ def rescueDB():
- def startInstall(pkgList):
- syncAll()
- portageExec = subprocess.Popen(['emerge', '-aq'] + pkgList)
-- portageExec.communicate()
-+ portageExec.wait()
- syncLocalDatabase()
-
- # call portage to uninstall the package(s) (CLI frontend)
-
- def startUninstall(pkgList):
- portageExec = subprocess.Popen(['emerge', '--depclean', '-aq'] + pkgList)
-- portageExec.communicate()
-+ portageExec.wait()
- syncLocalDatabase()
-
- # call portage to force-uninstall the package(s) (CLI frontend)
-
- def startUninstallForce(pkgList):
- portageExec = subprocess.Popen(['emerge', '--unmerge', '-aq'] + pkgList)
-- portageExec.communicate()
-+ portageExec.wait()
- syncLocalDatabase()
-
- # call portage to remove orphan package(s) (CLI frontend)
-
- def removeOrphans():
- portageExec = subprocess.Popen(['emerge', '--depclean', '-aq'])
-- portageExec.communicate()
-+ portageExec.wait()
- syncLocalDatabase()
-
- # call portage to perform a system upgrade (CLI frontend)
-@@ -221,7 +221,7 @@ def removeOrphans():
- def startUpgrade():
- syncAll()
- portageExec = subprocess.Popen(['emerge', '-uDaNq', '--backtrack=100', '--with-bdeps=y', '@world'])
-- portageExec.communicate()
-+ portageExec.wait()
- syncLocalDatabase()
-
- # call portage to search for package(s) (CLI frontend)
-diff --git a/src/frontend/gui/sisyphus-gui.py b/src/frontend/gui/sisyphus-gui.py
-index 406ea7a..0f290c8 100755
---- a/src/frontend/gui/sisyphus-gui.py
-+++ b/src/frontend/gui/sisyphus-gui.py
-@@ -377,6 +377,7 @@ def startInstall(self):
- atexit.register(portageKill, portageExec)
- for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
- self.strReady.emit(portageOutput.rstrip())
-+ portageExec.wait()
- syncLocalDatabase()
- self.finished.emit()
-
-@@ -389,6 +390,7 @@ def startUninstall(self):
- atexit.register(portageKill, portageExec)
- for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
- self.strReady.emit(portageOutput.rstrip())
-+ portageExec.wait()
- syncLocalDatabase()
- self.finished.emit()
-
-@@ -400,6 +402,7 @@ def startUpgrade(self):
- atexit.register(portageKill, portageExec)
- for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
- self.strReady.emit(portageOutput.rstrip())
-+ portageExec.wait()
- syncLocalDatabase()
- self.finished.emit()
-
-@@ -411,6 +414,7 @@ def cleanOrphans(self):
- atexit.register(portageKill, portageExec)
- for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
- self.strReady.emit(portageOutput.rstrip())
-+ portageExec.wait()
- syncLocalDatabase()
- self.finished.emit()
-
diff --git a/app-portage/sisyphus/sisyphus-1.1805-r9.ebuild b/app-portage/sisyphus/sisyphus-1.1809.ebuild
index 8a15e58a..fea62120 100644
--- a/app-portage/sisyphus/sisyphus-1.1805-r9.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1809.ebuild
@@ -1,47 +1,49 @@
-# Copyright 2016-2017 Redcore Linux Project
+# Copyright 2016-2018 Redcore Linux Project
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit eutils python-r1
+inherit eutils python-r1 git-r3
DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
HOMEPAGE="http://redcorelinux.org"
-SRC_URI="https://github.com/redcorelinux/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+EGIT_REPO_URI="https://pagure.io/redcore/sisyphus.git"
+EGIT_BRANCH="master"
+EGIT_COMMIT="ac10326fcf926f11fd21f69efd896b5ead503b26"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="+gui"
-PATCHES=( "${FILESDIR}"/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch
- "${FILESDIR}"/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
- "${FILESDIR}"/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch )
-
DEPEND="dev-lang/python[sqlite]"
RDEPEND="${DEPEND}
app-portage/gentoolkit[${PYTHON_USEDEP}]
+ app-portage/portage-utils
dev-python/animation[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wget[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]
- gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] sys-apps/gentoo-functions )"
+ sys-apps/gentoo-functions
+ gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] )"
src_install() {
default
inject_libsisyphus() {
- # FIXME, ugly hack
- python_moduleinto "$(python_get_sitedir)/.."
+ python_moduleinto "$(python_get_sitedir)"
python_domodule src/backend/libsisyphus.py
- rm -rf ${D}$(python_get_sitedir)
}
python_foreach_impl inject_libsisyphus
dosym /usr/share/${PN}/${PN}-cli.py /usr/bin/${PN}
dodir var/lib/${PN}/{csv,db}
+ keepdir var/lib/${PN}/{csv,db}
dodir etc/${PN}
insinto etc/${PN}