summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-28 01:30:08 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-28 01:30:08 +0100
commitf2f3fc0601dae0efdf582833e773ff9d87759ec9 (patch)
tree97b1dea93987ce46bd64cf8fab9fb1e8c4a9ea28 /app-portage
parent6bddf860d296ceb2f3d8c7823bda094973e287c0 (diff)
app-portage/sisyphus : fix gui shebang only when the gui is enabled
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/sisyphus-3.1910.1-r3.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-portage/sisyphus/sisyphus-3.1910.1-r3.ebuild b/app-portage/sisyphus/sisyphus-3.1910.1-r3.ebuild
index 31ba3828..01d9ecb0 100644
--- a/app-portage/sisyphus/sisyphus-3.1910.1-r3.ebuild
+++ b/app-portage/sisyphus/sisyphus-3.1910.1-r3.ebuild
@@ -63,5 +63,8 @@ src_install() {
# enforce best available python implementation
python_setup
python_fix_shebang "${ED}usr/share/${PN}/${PN}-cli.py"
- python_fix_shebang "${ED}usr/share/${PN}/${PN}-gui.py"
+
+ if use gui; then
+ python_fix_shebang "${ED}usr/share/${PN}/${PN}-gui.py"
+ fi
}