summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-13 14:45:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-13 14:45:27 +0100
commitdd248b5c5ce029aac8c7858ea56f492044f8592b (patch)
tree6586bf6f68955345c4b8833943faebad1b211b18 /app-portage
parent1e5ec4f60dedcd503c015ae1174acce32992ca41 (diff)
app-portage/sisyphus : revision bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/sisyphus-update.patch28
-rw-r--r--app-portage/sisyphus/sisyphus-1.1804-r3.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1804-r2.ebuild)1
2 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/sisyphus/files/sisyphus-update.patch b/app-portage/sisyphus/files/sisyphus-update.patch
new file mode 100644
index 00000000..f70fb862
--- /dev/null
+++ b/app-portage/sisyphus/files/sisyphus-update.patch
@@ -0,0 +1,28 @@
+diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
+index 069d563..e83258a 100755
+--- a/src/backend/libsisyphus.py
++++ b/src/backend/libsisyphus.py
+@@ -168,6 +168,10 @@ def startSearch(pkgList):
+ def startUpdate():
+ syncAll()
+
++def startSync():
++ syncGitRepos()
++ syncPortageCfg()
++
+ def sysInfo():
+ subprocess.check_call(['emerge', '--info'])
+
+diff --git a/src/frontend/cli/sisyphus-cli.py b/src/frontend/cli/sisyphus-cli.py
+index 965e3f1..9d347ab 100755
+--- a/src/frontend/cli/sisyphus-cli.py
++++ b/src/frontend/cli/sisyphus-cli.py
+@@ -18,7 +18,7 @@
+ elif "remove-orphans" in sys.argv[1:]:
+ removeOrphans()
+ elif "update" in sys.argv[1:]:
+- startUpdate()
++ startSync()
+ elif "upgrade" in sys.argv[1:]:
+ startUpgrade()
+ elif "search" in sys.argv[1:]:
diff --git a/app-portage/sisyphus/sisyphus-1.1804-r2.ebuild b/app-portage/sisyphus/sisyphus-1.1804-r3.ebuild
index b9b1f258..c781f2d9 100644
--- a/app-portage/sisyphus/sisyphus-1.1804-r2.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1804-r3.ebuild
@@ -28,6 +28,7 @@ src_prepare() {
default
eapply "${FILESDIR}"/"${PN}"-use-dateutil.patch
eapply "${FILESDIR}"/"${PN}"-drop-datetime.patch
+ eapply "${FILESDIR}"/"${PN}"-update.patch
}
src_install() {