summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-24 14:20:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-24 14:20:56 +0100
commit859e986656c6a98ab74f41a2860d3e54bce86120 (patch)
tree21159925c58aea62ec73c5ce5401d503504c5cb7 /app-portage
parent60a0678faf0c19a1e06cefd291f600725bc0988d (diff)
app-portage/sisyphus : revision bump (restrict sisyphus to binmode only)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch24
-rw-r--r--app-portage/sisyphus/sisyphus-1.1805-r9.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1805-r2.ebuild)3
2 files changed, 26 insertions, 1 deletions
diff --git a/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch b/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch
new file mode 100644
index 00000000..b817acbc
--- /dev/null
+++ b/app-portage/sisyphus/files/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch
@@ -0,0 +1,24 @@
+diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
+index 1d05b8c..1f15140 100755
+--- a/src/backend/libsisyphus.py
++++ b/src/backend/libsisyphus.py
+@@ -28,7 +28,6 @@ def checkRoot():
+
+ def checkSystemMode():
+ portage_binmode_make_conf = '/opt/redcore-build/conf/intel/portage/make.conf.amd64-binmode'
+- portage_mixedmode_make_conf = '/opt/redcore-build/conf/intel/portage/make.conf.amd64-mixedmode'
+ portage_make_conf_symlink = '/etc/portage/make.conf'
+
+ if not os.path.islink(portage_make_conf_symlink):
+@@ -37,10 +36,8 @@ def checkSystemMode():
+ else:
+ if os.path.realpath(portage_make_conf_symlink) == portage_binmode_make_conf:
+ pass
+- elif os.path.realpath(portage_make_conf_symlink) == portage_mixedmode_make_conf:
+- pass
+ else:
+- print("\nThe system is not set to binmode or mixedmode, refusing to run!\n")
++ print("\nThe system is not set to binmode, refusing to run!\n")
+ sys.exit(1)
+
+ # get current mirror information, so we know where we download from (CLI + GUI frontend)
diff --git a/app-portage/sisyphus/sisyphus-1.1805-r2.ebuild b/app-portage/sisyphus/sisyphus-1.1805-r9.ebuild
index 1bf42a85..8a15e58a 100644
--- a/app-portage/sisyphus/sisyphus-1.1805-r2.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1805-r9.ebuild
@@ -16,7 +16,8 @@ KEYWORDS="amd64 x86"
IUSE="+gui"
PATCHES=( "${FILESDIR}"/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch
- "${FILESDIR}"/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch )
+ "${FILESDIR}"/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
+ "${FILESDIR}"/3e34420beb774d76d1f3e6b4ed0efd2c3c5b3e65.patch )
DEPEND="dev-lang/python[sqlite]"
RDEPEND="${DEPEND}