summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-30 00:20:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-30 00:20:01 +0000
commit826d1b3f488d3549cbd42ccc73ad90ea1ce88f0b (patch)
treea84b9e02a2ed47c2b0cac999a53205ba3c7cc5ae /app-portage
parented5eafdd6cce789eb6b007f944fddf6f9f3174ba (diff)
app-portage/sisyphus : split => app-portage/sisyphus && app-portage/sisyphus-qt
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild36
-rw-r--r--app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch26
-rw-r--r--app-portage/sisyphus/sisyphus-4.2009.0-r2.ebuild (renamed from app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild)32
3 files changed, 42 insertions, 52 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild
new file mode 100644
index 00000000..598871c3
--- /dev/null
+++ b/app-portage/sisyphus-qt/sisyphus-qt-4.2009.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2016-2020 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-qt/}"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils python-r1 git-r3
+
+DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
+HOMEPAGE="http://redcorelinux.org"
+
+EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
+EGIT_BRANCH="master"
+EGIT_COMMIT="1b5d87dc8393295568f8f82a5d48fbc086f2caaf"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-lang/python[sqlite]"
+RDEPEND="${DEPEND}
+ app-misc/tmux
+ app-portage/sisyphus
+ dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]"
+
+src_install() {
+ emake DESTDIR=${D} install-gui
+
+ # enforce the best available python implementation (CLI)
+ python_setup
+ python_fix_shebang "${ED}usr/share/${MY_PN}/${MY_PN}-gui.py"
+}
diff --git a/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch b/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch
deleted file mode 100644
index cc5c48c6..00000000
--- a/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/backend/autoremove.py b/src/backend/autoremove.py
-index b5b732f9a15b023bc288e2ed81615b0129e2a567..497d8e5c66a263e52acd7b92c2fa4c22aaa4ff92 100644
---- a/src/backend/autoremove.py
-+++ b/src/backend/autoremove.py
-@@ -6,7 +6,7 @@ import sisyphus.database
- import sys
-
- def start():
-- if sisyphus.check.root() == 0:
-+ if sisyphus.check.root():
- portageExec = subprocess.Popen(['emerge', '--quiet', '--depclean', '--ask'])
- portageExec.wait()
- sisyphus.database.syncLocal()
-diff --git a/src/backend/branchsetup.py b/src/backend/branchsetup.py
-index e0d27a66ac56eccf93050388acdb0a962cf39028..0a54dd81e1e0f425604928d9c768c567573639a5 100644
---- a/src/backend/branchsetup.py
-+++ b/src/backend/branchsetup.py
-@@ -82,7 +82,7 @@ def warnAboutBinaryRepository(branch,remote):
-
-
- def start(branch,remote):
-- if sisyphus.check.root() == 0:
-+ if sisyphus.check.root():
- sisyphus.branchreset.start()
- injectGentooPortageTree(branch,remote)
- injectRedcoreEbuildOverlay(branch,remote)
diff --git a/app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild b/app-portage/sisyphus/sisyphus-4.2009.0-r2.ebuild
index ab13719d..48344e7a 100644
--- a/app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild
+++ b/app-portage/sisyphus/sisyphus-4.2009.0-r2.ebuild
@@ -12,16 +12,15 @@ HOMEPAGE="http://redcorelinux.org"
EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
EGIT_BRANCH="master"
-EGIT_COMMIT="02a67877e808bf2f3cf637bcc5694907ae6c2f00"
+EGIT_COMMIT="1b5d87dc8393295568f8f82a5d48fbc086f2caaf"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+gui"
+IUSE="qt5"
DEPEND="dev-lang/python[sqlite]"
RDEPEND="${DEPEND}
- app-misc/tmux
app-portage/gentoolkit[${PYTHON_USEDEP}]
app-portage/portage-utils
dev-python/animation[${PYTHON_USEDEP}]
@@ -31,19 +30,17 @@ RDEPEND="${DEPEND}
dev-python/wget[${PYTHON_USEDEP}]
sys-apps/portage[${PYTHON_USEDEP}]
sys-apps/gentoo-functions
- gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}/a23accad55705278cb19592c4af785dd182f36b7.patch" )
+ qt5? ( app-portage/sisyphus-qt )"
src_install() {
- default
+ emake DESTDIR=${D} install-cli
- inject_libsisyphus() {
+ inject_backend() {
python_moduleinto "$(python_get_sitedir)"/"${PN}"
python_domodule src/backend/*.py
}
- python_foreach_impl inject_libsisyphus
+ python_foreach_impl inject_backend
dosym /usr/share/${PN}/${PN}-cli.py /usr/bin/${PN}
keepdir var/lib/${PN}/{csv,db}
@@ -52,24 +49,7 @@ src_install() {
insinto etc/${PN}
doins ${FILESDIR}/mirrors.conf
- if ! use gui; then
- rm -rf ${ED}usr/bin/${PN}-gui
- rm -rf ${ED}usr/bin/${PN}-gui-pkexec
- rm -rf ${ED}usr/share/${PN}/${PN}-gui.py
- rm -rf ${ED}usr/share/${PN}/icon
- rm -rf ${ED}usr/share/${PN}/ui
- rm -rf ${ED}usr/share/applications
- rm -rf ${ED}usr/share/pixmaps
- rm -rf ${ED}usr/share/polkit-1
- fi
-
# enforce the best available python implementation (CLI)
python_setup
python_fix_shebang "${ED}usr/share/${PN}/${PN}-cli.py"
-
- # enforce the best available python implementation (GUI)
- if use gui; then
- python_setup
- python_fix_shebang "${ED}usr/share/${PN}/${PN}-gui.py"
- fi
}