summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-09-30 19:52:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-09-30 19:52:33 +0100
commit61a38851d8aa29e434ace62404f65f61312399d7 (patch)
tree7cb9b9bf55ee7570f581e1b159e76a77769a9159 /app-portage
parent3d2825f4c8b8747ade1046843659665007ddc7b0 (diff)
app-portage/sisyphus : revision bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/sisyphus-1.1709-r1.patch30
-rw-r--r--app-portage/sisyphus/sisyphus-1.1709-r1.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1709.ebuild)5
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/sisyphus/files/sisyphus-1.1709-r1.patch b/app-portage/sisyphus/files/sisyphus-1.1709-r1.patch
new file mode 100644
index 00000000..2d70bd93
--- /dev/null
+++ b/app-portage/sisyphus/files/sisyphus-1.1709-r1.patch
@@ -0,0 +1,30 @@
+diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
+index f49e9da..2f8e150 100755
+--- a/src/backend/libsisyphus.py
++++ b/src/backend/libsisyphus.py
+@@ -254,12 +254,6 @@ def sisyphus_pkg_sysinfo():
+ subprocess.check_call(['emerge', '--info'])
+
+ def sisyphus_db_rescue():
+- if os.path.exists(sisyphus_remote_csv_path_pre):
+- os.remove(sisyphus_remote_csv_path_pre)
+- if os.path.exists(sisyphus_removable_csv_path_pre):
+- os.remove(sisyphus_removable_csv_path_pre)
+- if os.path.exists(sisyphus_local_csv_path_pre):
+- os.remove(sisyphus_local_csv_path_pre)
+ if os.path.exists(sisyphus_database_path):
+ os.remove(sisyphus_database_path)
+ sisyphus_pkg_system_update()
+diff --git a/src/frontend/cli/sisyphus-cli.py b/src/frontend/cli/sisyphus-cli.py
+index ee90c6f..c8a8bd9 100755
+--- a/src/frontend/cli/sisyphus-cli.py
++++ b/src/frontend/cli/sisyphus-cli.py
+@@ -17,7 +17,7 @@
+ elif "remove-orphans" in sys.argv[1:]:
+ sisyphus_pkg_remove_orphans()
+ elif "update" in sys.argv[1:]:
+- sisyphus_pkg_system_update
++ sisyphus_pkg_system_update()
+ elif "upgrade" in sys.argv[1:]:
+ sisyphus_pkg_system_upgrade()
+ elif "search" in sys.argv[1:]:
diff --git a/app-portage/sisyphus/sisyphus-1.1709.ebuild b/app-portage/sisyphus/sisyphus-1.1709-r1.ebuild
index cbf83f20..97b61297 100644
--- a/app-portage/sisyphus/sisyphus-1.1709.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1709-r1.ebuild
@@ -24,6 +24,11 @@ RDEPEND="${DEPEND}
sys-apps/portage[${PYTHON_USEDEP}]
gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] )"
+src_prepare() {
+ default
+ epatch ${FILESDIR}/${P}-r1.patch
+}
+
src_install() {
default
dosym /usr/share/${PN}/${PN}-cli.py /usr/bin/${PN}