summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 23:12:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 23:12:49 +0000
commit3c76b95e9ba3502f2d2bad7d6eea55278623a31a (patch)
treed184d146271ec270a109f6b15e68352f34e0d590 /app-portage
parent2aa9c4863eeceb0e19d4c9ffc008a35398cd3e07 (diff)
app-portage/sisyphus : with python-single-r1 ECLASS, our backend injection hack is no longer needed
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/sisyphus-4.2012.0.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/app-portage/sisyphus/sisyphus-4.2012.0.ebuild b/app-portage/sisyphus/sisyphus-4.2012.0.ebuild
index 305771fe..ff7c507f 100644
--- a/app-portage/sisyphus/sisyphus-4.2012.0.ebuild
+++ b/app-portage/sisyphus/sisyphus-4.2012.0.ebuild
@@ -37,12 +37,8 @@ PDEPEND="qt5? ( ~app-portage/sisyphus-qt-${PV} )"
src_install() {
emake DESTDIR=${D} install-cli
- inject_backend() {
- python_moduleinto "$(python_get_sitedir)"/"${PN}"
- python_domodule src/backend/*.py
- }
-
- python_foreach_impl inject_backend
+ python_moduleinto "$(python_get_sitedir)"/"${PN}"
+ python_domodule src/backend/*.py
dosym /usr/share/${PN}/${PN}-cli.py /usr/bin/${PN}
keepdir var/lib/${PN}/{csv,db}