summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-22 16:31:09 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-22 16:31:09 +0000
commit3858e01d1347c89a77d2693013477a33aa33c5cc (patch)
treeabc75d10dbe8ce032dd603e834b188dd86fce130 /app-portage
parentf7fd5a36dd7bf6c31fdf1271fd5e92eedc53a9b5 (diff)
app-portage/sisyphus : revision bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/sisyphus-1.1710-r4.patch (renamed from app-portage/sisyphus/files/sisyphus-1.1710-r3.patch)20
-rw-r--r--app-portage/sisyphus/sisyphus-1.1710-r4.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1710-r3.ebuild)2
2 files changed, 20 insertions, 2 deletions
diff --git a/app-portage/sisyphus/files/sisyphus-1.1710-r3.patch b/app-portage/sisyphus/files/sisyphus-1.1710-r4.patch
index 5898f921..de2d6096 100644
--- a/app-portage/sisyphus/files/sisyphus-1.1710-r3.patch
+++ b/app-portage/sisyphus/files/sisyphus-1.1710-r4.patch
@@ -25,7 +25,7 @@ index 4d9785d..af54dfd 100644
rm -rf $(DESTDIR)$(SISYPHUSDATADIR)
- rm -rf $(DESTDIR)$(SISYPHUSPYLIBDIR)/libsisyphus.py
diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
-index 5f62119..4f7fda5 100755
+index 5f62119..a18e1cc 100755
--- a/src/backend/libsisyphus.py
+++ b/src/backend/libsisyphus.py
@@ -112,10 +112,24 @@ def sync_sisyphus_database_removable_packages_table():
@@ -57,6 +57,24 @@ index 5f62119..4f7fda5 100755
def generate_sisyphus_local_packages_table_csv_pre():
subprocess.check_call(['/usr/share/sisyphus/helpers/make_local_csv_pre']) # this is really hard to do in python, so we cheat with a bash helper script
+@@ -229,7 +243,7 @@ def sisyphus_pkg_auto_remove_orphans():
+ def sisyphus_pkg_system_upgrade():
+ redcore_sync()
+ generate_sisyphus_local_packages_table_csv_pre()
+- portage_call = subprocess.Popen(['emerge', '-uDaNq', '--with-bdeps=y', '@world'])
++ portage_call = subprocess.Popen(['emerge', '-uDaNq', '--backtrack=100', '--with-bdeps=y', '@world'])
+ atexit.register(kill_bg_portage, portage_call)
+ portage_call.communicate()
+ generate_sisyphus_local_packages_table_csv_post()
+@@ -238,7 +252,7 @@ def sisyphus_pkg_system_upgrade():
+ def sisyphus_pkg_auto_system_upgrade():
+ redcore_sync()
+ generate_sisyphus_local_packages_table_csv_pre()
+- portage_call = subprocess.Popen(['emerge', '-uDNq', '--with-bdeps=y', '@world'])
++ portage_call = subprocess.Popen(['emerge', '-uDNq', '--backtrack=100', '--with-bdeps=y', '@world'])
+ atexit.register(kill_bg_portage, portage_call)
+ portage_call.communicate()
+ generate_sisyphus_local_packages_table_csv_post()
diff --git a/src/frontend/gui/sisyphus-gui.py b/src/frontend/gui/sisyphus-gui.py
index d64f431..027c90c 100755
--- a/src/frontend/gui/sisyphus-gui.py
diff --git a/app-portage/sisyphus/sisyphus-1.1710-r3.ebuild b/app-portage/sisyphus/sisyphus-1.1710-r4.ebuild
index ac58c753..f83af50c 100644
--- a/app-portage/sisyphus/sisyphus-1.1710-r3.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1710-r4.ebuild
@@ -26,7 +26,7 @@ RDEPEND="${DEPEND}
src_prepare() {
default
- eapply ${FILESDIR}/${P}-r3.patch
+ eapply ${FILESDIR}/${P}-r4.patch
}
src_install() {