summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-21 14:52:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-21 14:52:44 +0000
commit36f3ac653f9441a014349f81c67d9b801244ad40 (patch)
tree0b64e0c87eefbbde9a4b0ed5df5b1744e9c798ea /app-portage
parentd9b78acfb55a9cf01c6617c66eecbda651ebc852 (diff)
app-portage/sisyphus : revision bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/mirrors.conf2
-rw-r--r--app-portage/sisyphus/files/sisyphus-1.1801-remove-csv-hardcode.patch45
-rw-r--r--app-portage/sisyphus/sisyphus-1.1801-r3.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1801-r2.ebuild)5
3 files changed, 51 insertions, 1 deletions
diff --git a/app-portage/sisyphus/files/mirrors.conf b/app-portage/sisyphus/files/mirrors.conf
index dbb55599..e5919f3e 100644
--- a/app-portage/sisyphus/files/mirrors.conf
+++ b/app-portage/sisyphus/files/mirrors.conf
@@ -7,4 +7,4 @@
# PORTAGE_BINHOST="http://mirror.math.princeton.edu/pub/redcorelinux/packages/"
# Alpix.eu (DE) mirror
-PORTAGE_BINHOST="https://mirror.alpix.eu/redcorelinux/packages/"
+PORTAGE_BINHOST="http://mirror.alpix.eu/redcorelinux/packages/"
diff --git a/app-portage/sisyphus/files/sisyphus-1.1801-remove-csv-hardcode.patch b/app-portage/sisyphus/files/sisyphus-1.1801-remove-csv-hardcode.patch
new file mode 100644
index 00000000..2d0befa0
--- /dev/null
+++ b/app-portage/sisyphus/files/sisyphus-1.1801-remove-csv-hardcode.patch
@@ -0,0 +1,45 @@
+diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
+index defc5cf..6a89563 100755
+--- a/src/backend/libsisyphus.py
++++ b/src/backend/libsisyphus.py
+@@ -10,15 +10,14 @@
+ import sys
+ import time
+ import urllib3
++import io
+
+ redcore_portage_tree_path = '/usr/portage'
+ redcore_desktop_overlay_path = '/var/lib/layman/redcore-desktop'
+ redcore_portage_config_path = '/opt/redcore-build'
+
+-sisyphus_remote_csv_url = 'http://mirror.math.princeton.edu/pub/redcorelinux/csv/remote_packages_pre.csv'
+ sisyphus_remote_csv_path_pre = '/var/lib/sisyphus/csv/remote_packages_pre.csv'
+ sisyphus_remote_csv_path_post = '/var/lib/sisyphus/csv/remote_packages_post.csv'
+-sisyphus_removable_csv_url = 'http://mirror.math.princeton.edu/pub/redcorelinux/csv/removable_packages_pre.csv'
+ sisyphus_removable_csv_path_pre = '/var/lib/sisyphus/csv/removable_packages_pre.csv'
+ sisyphus_removable_csv_path_post = '/var/lib/sisyphus/csv/removable_packages_post.csv'
+ sisyphus_local_csv_path_pre = '/var/lib/sisyphus/csv/local_packages_pre.csv'
+@@ -48,6 +47,11 @@ def check_system_mode():
+ sys.exit(1)
+
+ def fetch_sisyphus_remote_packages_table_csv():
++ portage_call = subprocess.Popen(['emerge', '--info', '--verbose'], stdout=subprocess.PIPE)
++ for portage_output in io.TextIOWrapper(portage_call.stdout, encoding="utf-8"):
++ if "PORTAGE_BINHOST" in portage_output.rstrip():
++ sisyphus_remote_csv_url = str(portage_output.rstrip().split("=")[1].strip('\"').strip('/packages') + '/csv' + '/remote_packages_pre.csv')
++
+ http = urllib3.PoolManager()
+
+ if not os.path.isfile(sisyphus_remote_csv_path_pre):
+@@ -59,6 +63,11 @@ def fetch_sisyphus_remote_packages_table_csv():
+ shutil.copyfileobj(tmp_buffer, output_file)
+
+ def fetch_sisyphus_removable_packages_table_csv():
++ portage_call = subprocess.Popen(['emerge', '--info', '--verbose'], stdout=subprocess.PIPE)
++ for portage_output in io.TextIOWrapper(portage_call.stdout, encoding="utf-8"):
++ if "PORTAGE_BINHOST" in portage_output.rstrip():
++ sisyphus_removable_csv_url = str(portage_output.rstrip().split("=")[1].strip('\"').strip('/packages') + '/csv' + '/removable_packages_pre.csv')
++
+ http = urllib3.PoolManager()
+
+ if not os.path.isfile(sisyphus_removable_csv_path_pre):
diff --git a/app-portage/sisyphus/sisyphus-1.1801-r2.ebuild b/app-portage/sisyphus/sisyphus-1.1801-r3.ebuild
index f479ea57..cfb091c3 100644
--- a/app-portage/sisyphus/sisyphus-1.1801-r2.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1801-r3.ebuild
@@ -23,6 +23,11 @@ RDEPEND="${DEPEND}
sys-apps/portage[${PYTHON_USEDEP}]
gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] sys-apps/gentoo-functions )"
+src_prepare() {
+ default
+ eapply "${FILESDIR}/${P}-remove-csv-hardcode.patch"
+}
+
src_install() {
default