summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-19 14:54:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-19 14:54:01 +0100
commit29435f2aed08a4d28c14bdc2c88ca5ca3f8b06ee (patch)
tree03c4c3dd7a6889ff51dad77aee593a670263667b /app-portage
parentc2ea6c6bd0f8b53b033dae540fd02368353a68b5 (diff)
app-portage/sisyphus : revision bump (apply zombie process kill fix)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch82
-rw-r--r--app-portage/sisyphus/sisyphus-1.1805-r2.ebuild (renamed from app-portage/sisyphus/sisyphus-1.1805-r1.ebuild)7
2 files changed, 84 insertions, 5 deletions
diff --git a/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch b/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
new file mode 100644
index 00000000..55af7a86
--- /dev/null
+++ b/app-portage/sisyphus/files/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch
@@ -0,0 +1,82 @@
+diff --git a/src/backend/libsisyphus.py b/src/backend/libsisyphus.py
+index ac7d7b2..1d05b8c 100755
+--- a/src/backend/libsisyphus.py
++++ b/src/backend/libsisyphus.py
+@@ -192,28 +192,28 @@ def rescueDB():
+ def startInstall(pkgList):
+ syncAll()
+ portageExec = subprocess.Popen(['emerge', '-aq'] + pkgList)
+- portageExec.communicate()
++ portageExec.wait()
+ syncLocalDatabase()
+
+ # call portage to uninstall the package(s) (CLI frontend)
+
+ def startUninstall(pkgList):
+ portageExec = subprocess.Popen(['emerge', '--depclean', '-aq'] + pkgList)
+- portageExec.communicate()
++ portageExec.wait()
+ syncLocalDatabase()
+
+ # call portage to force-uninstall the package(s) (CLI frontend)
+
+ def startUninstallForce(pkgList):
+ portageExec = subprocess.Popen(['emerge', '--unmerge', '-aq'] + pkgList)
+- portageExec.communicate()
++ portageExec.wait()
+ syncLocalDatabase()
+
+ # call portage to remove orphan package(s) (CLI frontend)
+
+ def removeOrphans():
+ portageExec = subprocess.Popen(['emerge', '--depclean', '-aq'])
+- portageExec.communicate()
++ portageExec.wait()
+ syncLocalDatabase()
+
+ # call portage to perform a system upgrade (CLI frontend)
+@@ -221,7 +221,7 @@ def removeOrphans():
+ def startUpgrade():
+ syncAll()
+ portageExec = subprocess.Popen(['emerge', '-uDaNq', '--backtrack=100', '--with-bdeps=y', '@world'])
+- portageExec.communicate()
++ portageExec.wait()
+ syncLocalDatabase()
+
+ # call portage to search for package(s) (CLI frontend)
+diff --git a/src/frontend/gui/sisyphus-gui.py b/src/frontend/gui/sisyphus-gui.py
+index 406ea7a..0f290c8 100755
+--- a/src/frontend/gui/sisyphus-gui.py
++++ b/src/frontend/gui/sisyphus-gui.py
+@@ -377,6 +377,7 @@ def startInstall(self):
+ atexit.register(portageKill, portageExec)
+ for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
+ self.strReady.emit(portageOutput.rstrip())
++ portageExec.wait()
+ syncLocalDatabase()
+ self.finished.emit()
+
+@@ -389,6 +390,7 @@ def startUninstall(self):
+ atexit.register(portageKill, portageExec)
+ for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
+ self.strReady.emit(portageOutput.rstrip())
++ portageExec.wait()
+ syncLocalDatabase()
+ self.finished.emit()
+
+@@ -400,6 +402,7 @@ def startUpgrade(self):
+ atexit.register(portageKill, portageExec)
+ for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
+ self.strReady.emit(portageOutput.rstrip())
++ portageExec.wait()
+ syncLocalDatabase()
+ self.finished.emit()
+
+@@ -411,6 +414,7 @@ def cleanOrphans(self):
+ atexit.register(portageKill, portageExec)
+ for portageOutput in io.TextIOWrapper(portageExec.stdout, encoding="utf-8"):
+ self.strReady.emit(portageOutput.rstrip())
++ portageExec.wait()
+ syncLocalDatabase()
+ self.finished.emit()
+
diff --git a/app-portage/sisyphus/sisyphus-1.1805-r1.ebuild b/app-portage/sisyphus/sisyphus-1.1805-r2.ebuild
index 1ebe7f8b..1bf42a85 100644
--- a/app-portage/sisyphus/sisyphus-1.1805-r1.ebuild
+++ b/app-portage/sisyphus/sisyphus-1.1805-r2.ebuild
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="+gui"
-PATCHES=( "${FILESDIR}"/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch )
+PATCHES=( "${FILESDIR}"/30fb816f2482fd06a60b557de5bf7cf6e8212d2a.patch
+ "${FILESDIR}"/4fa81a14d7e657e3976c26c64748b5963a55c56d.patch )
DEPEND="dev-lang/python[sqlite]"
RDEPEND="${DEPEND}
@@ -56,7 +57,3 @@ src_install() {
rm -rf ${ED}usr/share/polkit-1
fi
}
-
-pkg_postinst() {
- sisyphus rescue
-}