summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-03 20:18:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-03 20:18:47 +0100
commit238b6d6c20fe99938af667db240270a01bdad4fa (patch)
tree5379feaec07d309dde42ca2a7f541a9039fdf5d6 /app-portage
parent187700bff2ecd89787ea62ec7d5c424e403e6702 (diff)
app-portage/sisyphus : revision bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/sisyphus/files/sisyphus-makeopts.patch26
-rw-r--r--app-portage/sisyphus/files/sisyphus.build-env.conf (renamed from app-portage/sisyphus/files/sisyphus.env.conf)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.make-conf.conf (renamed from app-portage/sisyphus/files/sisyphus.make.conf)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.make-opts.conf3
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-env.conf (renamed from app-portage/sisyphus/files/sisyphus.package.env)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-keywords.conf (renamed from app-portage/sisyphus/files/sisyphus.package.keywords)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-license.conf (renamed from app-portage/sisyphus/files/sisyphus.package.license)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-mask.conf (renamed from app-portage/sisyphus/files/sisyphus.package.mask)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-unmask.conf (renamed from app-portage/sisyphus/files/sisyphus.package.unmask)0
-rw-r--r--app-portage/sisyphus/files/sisyphus.package-use.conf (renamed from app-portage/sisyphus/files/sisyphus.package.use)0
-rw-r--r--app-portage/sisyphus/sisyphus-6.2305.0-r1.ebuild (renamed from app-portage/sisyphus/sisyphus-6.2305.0.ebuild)19
11 files changed, 40 insertions, 8 deletions
diff --git a/app-portage/sisyphus/files/sisyphus-makeopts.patch b/app-portage/sisyphus/files/sisyphus-makeopts.patch
new file mode 100644
index 00000000..1a44b9fa
--- /dev/null
+++ b/app-portage/sisyphus/files/sisyphus-makeopts.patch
@@ -0,0 +1,26 @@
+diff --git a/src/helpers/set_jobs b/src/helpers/set_jobs
+index df3e080..b04c965 100755
+--- a/src/helpers/set_jobs
++++ b/src/helpers/set_jobs
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env bash
+
+-portageConfigDir="/opt/redcore-build/conf/intel/portage"
++sisyphusConfigDir="/etc/sisyphus"
+
+ setjobs () {
+ # default MAKEOPTS value is -j64, but that's overkill for lower spec machines
+@@ -8,11 +8,9 @@ setjobs () {
+ # however since compilation is largely pointer-following, SMT won't help much
+ # and can lead to memory starvation and stalls; DO NOT use logical cores
+ if [[ $(cat /sys/devices/system/cpu/smt/active) -eq 1 ]]; then
+- sed -i "s/\-j\([0-9]\+\)/\-j$(expr $(getconf _NPROCESSORS_ONLN) / 2)/g" "$portageConfigDir"/make.conf/00-makeopts.conf >/dev/null 2>&1 # global makeopts (exclude kernel)
+- sed -i "s/\-j\([0-9]\+\)/\-j$(expr $(getconf _NPROCESSORS_ONLN) / 2)/g" "$portageConfigDir"/env/makenoise.conf >/dev/null 2>&1 # kernel makeopts
++ sed -i "s/\-j\([0-9]\+\)/\-j$(expr $(getconf _NPROCESSORS_ONLN) / 2)/g" "$sisyphusConfigDir"/sisyphus.make-opts.conf >/dev/null 2>&1 # global makeopts
+ elif [[ $(cat /sys/devices/system/cpu/smt/active) -eq 0 ]]; then
+- sed -i "s/\-j\([0-9]\+\)/\-j$(getconf _NPROCESSORS_ONLN)/g" "$portageConfigDir"/make.conf/00-makeopts.conf >/dev/null 2>&1 # global makeopts (exclude kernel)
+- sed -i "s/\-j\([0-9]\+\)/\-j$(getconf _NPROCESSORS_ONLN)/g" "$portageConfigDir"/env/makenoise.conf >/dev/null 2>&1 # kernel makeopts
++ sed -i "s/\-j\([0-9]\+\)/\-j$(getconf _NPROCESSORS_ONLN)/g" "$sisyphusConfigDir"/sisyphus.make-opts.conf >/dev/null 2>&1 # global makeopts
+ fi
+ }
+
diff --git a/app-portage/sisyphus/files/sisyphus.env.conf b/app-portage/sisyphus/files/sisyphus.build-env.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.env.conf
+++ b/app-portage/sisyphus/files/sisyphus.build-env.conf
diff --git a/app-portage/sisyphus/files/sisyphus.make.conf b/app-portage/sisyphus/files/sisyphus.make-conf.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.make.conf
+++ b/app-portage/sisyphus/files/sisyphus.make-conf.conf
diff --git a/app-portage/sisyphus/files/sisyphus.make-opts.conf b/app-portage/sisyphus/files/sisyphus.make-opts.conf
new file mode 100644
index 00000000..79d3bc18
--- /dev/null
+++ b/app-portage/sisyphus/files/sisyphus.make-opts.conf
@@ -0,0 +1,3 @@
+# This file has been automatically generated, do not edit.
+
+MAKEOPTS="-j64"
diff --git a/app-portage/sisyphus/files/sisyphus.package.env b/app-portage/sisyphus/files/sisyphus.package-env.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.env
+++ b/app-portage/sisyphus/files/sisyphus.package-env.conf
diff --git a/app-portage/sisyphus/files/sisyphus.package.keywords b/app-portage/sisyphus/files/sisyphus.package-keywords.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.keywords
+++ b/app-portage/sisyphus/files/sisyphus.package-keywords.conf
diff --git a/app-portage/sisyphus/files/sisyphus.package.license b/app-portage/sisyphus/files/sisyphus.package-license.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.license
+++ b/app-portage/sisyphus/files/sisyphus.package-license.conf
diff --git a/app-portage/sisyphus/files/sisyphus.package.mask b/app-portage/sisyphus/files/sisyphus.package-mask.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.mask
+++ b/app-portage/sisyphus/files/sisyphus.package-mask.conf
diff --git a/app-portage/sisyphus/files/sisyphus.package.unmask b/app-portage/sisyphus/files/sisyphus.package-unmask.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.unmask
+++ b/app-portage/sisyphus/files/sisyphus.package-unmask.conf
diff --git a/app-portage/sisyphus/files/sisyphus.package.use b/app-portage/sisyphus/files/sisyphus.package-use.conf
index e69de29b..e69de29b 100644
--- a/app-portage/sisyphus/files/sisyphus.package.use
+++ b/app-portage/sisyphus/files/sisyphus.package-use.conf
diff --git a/app-portage/sisyphus/sisyphus-6.2305.0.ebuild b/app-portage/sisyphus/sisyphus-6.2305.0-r1.ebuild
index 1ec80bb1..ce80d9f6 100644
--- a/app-portage/sisyphus/sisyphus-6.2305.0.ebuild
+++ b/app-portage/sisyphus/sisyphus-6.2305.0-r1.ebuild
@@ -34,6 +34,8 @@ RDEPEND="${DEPEND}
sys-apps/gentoo-functions"
PDEPEND="qt5? ( ~app-portage/${PN}-qt-${PV} )"
+PATCHES=( "${FILESDIR}"/"${PN}"-makeopts.patch )
+
src_install() {
emake DESTDIR="${D}"/ install-cli
@@ -48,14 +50,15 @@ src_install() {
doins "${FILESDIR}"/"${PN}"-mirrors-amd64.conf
doins "${FILESDIR}"/"${PN}"-mirrors-arm64.conf
- doins "${FILESDIR}"/"${PN}".env.conf
- doins "${FILESDIR}"/"${PN}".make.conf
- doins "${FILESDIR}"/"${PN}".package.keywords
- doins "${FILESDIR}"/"${PN}".package.env
- doins "${FILESDIR}"/"${PN}".package.license
- doins "${FILESDIR}"/"${PN}".package.mask
- doins "${FILESDIR}"/"${PN}".package.unmask
- doins "${FILESDIR}"/"${PN}".package.use
+ doins "${FILESDIR}"/"${PN}".build-env.conf
+ doins "${FILESDIR}"/"${PN}".make-conf.conf
+ doins "${FILESDIR}"/"${PN}".make-opts.conf
+ doins "${FILESDIR}"/"${PN}".package-keywords.conf
+ doins "${FILESDIR}"/"${PN}".package-env.conf
+ doins "${FILESDIR}"/"${PN}".package-license.conf
+ doins "${FILESDIR}"/"${PN}".package-mask.conf
+ doins "${FILESDIR}"/"${PN}".package-unmask.conf
+ doins "${FILESDIR}"/"${PN}".package-use.conf
# enforce the best available python implementation (CLI)
python_setup