summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-20 14:37:50 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-20 14:37:50 +0100
commit52289c7eaff05922a923ed72944a8e1961b53cb1 (patch)
tree9c7fe4161297d312c5ef129c4768a899b3f3765f /app-portage/sisyphus
parentead10bd46f2dc8d371717f1104d6460004757228 (diff)
app-portage/sisyphus : revision bump (hotfix)
Diffstat (limited to 'app-portage/sisyphus')
-rw-r--r--app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch26
-rw-r--r--app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild (renamed from app-portage/sisyphus/sisyphus-4.2009.0.ebuild)2
2 files changed, 28 insertions, 0 deletions
diff --git a/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch b/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch
new file mode 100644
index 00000000..cc5c48c6
--- /dev/null
+++ b/app-portage/sisyphus/files/a23accad55705278cb19592c4af785dd182f36b7.patch
@@ -0,0 +1,26 @@
+diff --git a/src/backend/autoremove.py b/src/backend/autoremove.py
+index b5b732f9a15b023bc288e2ed81615b0129e2a567..497d8e5c66a263e52acd7b92c2fa4c22aaa4ff92 100644
+--- a/src/backend/autoremove.py
++++ b/src/backend/autoremove.py
+@@ -6,7 +6,7 @@ import sisyphus.database
+ import sys
+
+ def start():
+- if sisyphus.check.root() == 0:
++ if sisyphus.check.root():
+ portageExec = subprocess.Popen(['emerge', '--quiet', '--depclean', '--ask'])
+ portageExec.wait()
+ sisyphus.database.syncLocal()
+diff --git a/src/backend/branchsetup.py b/src/backend/branchsetup.py
+index e0d27a66ac56eccf93050388acdb0a962cf39028..0a54dd81e1e0f425604928d9c768c567573639a5 100644
+--- a/src/backend/branchsetup.py
++++ b/src/backend/branchsetup.py
+@@ -82,7 +82,7 @@ def warnAboutBinaryRepository(branch,remote):
+
+
+ def start(branch,remote):
+- if sisyphus.check.root() == 0:
++ if sisyphus.check.root():
+ sisyphus.branchreset.start()
+ injectGentooPortageTree(branch,remote)
+ injectRedcoreEbuildOverlay(branch,remote)
diff --git a/app-portage/sisyphus/sisyphus-4.2009.0.ebuild b/app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild
index f23c74cd..ab13719d 100644
--- a/app-portage/sisyphus/sisyphus-4.2009.0.ebuild
+++ b/app-portage/sisyphus/sisyphus-4.2009.0-r1.ebuild
@@ -33,6 +33,8 @@ RDEPEND="${DEPEND}
sys-apps/gentoo-functions
gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/a23accad55705278cb19592c4af785dd182f36b7.patch" )
+
src_install() {
default