summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus/sisyphus-4.2006.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-07-04 16:33:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-07-04 16:33:38 +0100
commit3f081bc83000affd8ec16e0b941c6c08925ea098 (patch)
tree3b7d4e8ed8f6687e8797890c74adf7fad364fee8 /app-portage/sisyphus/sisyphus-4.2006.0.ebuild
parent24926a514b67a48ccf492acb25562fd7ce85b939 (diff)
app-portage/sisyphus : version bump
Diffstat (limited to 'app-portage/sisyphus/sisyphus-4.2006.0.ebuild')
-rw-r--r--app-portage/sisyphus/sisyphus-4.2006.0.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/app-portage/sisyphus/sisyphus-4.2006.0.ebuild b/app-portage/sisyphus/sisyphus-4.2006.0.ebuild
deleted file mode 100644
index 6abeae8c..00000000
--- a/app-portage/sisyphus/sisyphus-4.2006.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2016-2018 Redcore Linux Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit eutils python-r1 git-r3
-
-DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
-HOMEPAGE="http://redcorelinux.org"
-
-EGIT_REPO_URI="https://gitlab.com/redcore/sisyphus.git"
-EGIT_BRANCH="master"
-EGIT_COMMIT="94435dc8ad302c54448fdfe5b1add8d9a2b264f9"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+gui"
-
-DEPEND="dev-lang/python[sqlite]"
-RDEPEND="${DEPEND}
- app-misc/tmux
- app-portage/gentoolkit[${PYTHON_USEDEP}]
- app-portage/portage-utils
- dev-python/animation[${PYTHON_USEDEP}]
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/typer[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wget[${PYTHON_USEDEP}]
- sys-apps/portage[${PYTHON_USEDEP}]
- sys-apps/gentoo-functions
- gui? ( dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}] )"
-
-src_install() {
- default
-
- inject_libsisyphus() {
- python_moduleinto "$(python_get_sitedir)"/"${PN}"
- python_domodule src/backend/*.py
- }
-
- python_foreach_impl inject_libsisyphus
-
- dosym /usr/share/${PN}/${PN}-cli.py /usr/bin/${PN}
- keepdir var/lib/${PN}/{csv,db}
-
- dodir etc/${PN}
- insinto etc/${PN}
- doins ${FILESDIR}/mirrors.conf
-
- if ! use gui; then
- rm -rf ${ED}usr/bin/${PN}-gui
- rm -rf ${ED}usr/bin/${PN}-gui-pkexec
- rm -rf ${ED}usr/share/${PN}/${PN}-gui.py
- rm -rf ${ED}usr/share/${PN}/icon
- rm -rf ${ED}usr/share/${PN}/ui
- rm -rf ${ED}usr/share/applications
- rm -rf ${ED}usr/share/pixmaps
- rm -rf ${ED}usr/share/polkit-1
- fi
-
- # enforce the best available python implementation (CLI)
- python_setup
- python_fix_shebang "${ED}usr/share/${PN}/${PN}-cli.py"
-
- # enforce the best available python implementation (GUI)
- if use gui; then
- python_setup
- python_fix_shebang "${ED}usr/share/${PN}/${PN}-gui.py"
- fi
-}