summaryrefslogtreecommitdiff
path: root/app-portage/sisyphus-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 22:56:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 22:56:07 +0000
commitdf46b49a6c54f5386860eae497868e612bf0e7b8 (patch)
tree44a35eafe4468ca9f0ff60e5ae8476fd05c17fcc /app-portage/sisyphus-qt
parent62f9f3644a20d13b312f66e7507de29090a4d5fc (diff)
app-portage/sisyphus{,qt} : port to python-single-r1 ECLASS
Diffstat (limited to 'app-portage/sisyphus-qt')
-rw-r--r--app-portage/sisyphus-qt/sisyphus-qt-4.2012.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-portage/sisyphus-qt/sisyphus-qt-4.2012.0.ebuild b/app-portage/sisyphus-qt/sisyphus-qt-4.2012.0.ebuild
index c5f9e67c..50f5919d 100644
--- a/app-portage/sisyphus-qt/sisyphus-qt-4.2012.0.ebuild
+++ b/app-portage/sisyphus-qt/sisyphus-qt-4.2012.0.ebuild
@@ -7,7 +7,7 @@ MY_PN="${PN/-qt/}"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit eutils python-r1 git-r3
+inherit eutils python-single-r1 git-r3
DESCRIPTION="A simple portage python wrapper which works like other package managers(apt-get/yum/dnf)"
HOMEPAGE="http://redcorelinux.org"
@@ -22,10 +22,12 @@ KEYWORDS="amd64 x86"
IUSE=""
DEPEND="dev-lang/python[sqlite]
- ~app-portage/sisyphus-${PV}[${PYTHON_USEDEP}]"
+ ~app-portage/sisyphus-${PV}"
RDEPEND="${DEPEND}
app-misc/tmux
- dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[designer,gui,widgets,${PYTHON_USEDEP}]
+ ')"
src_install() {
emake DESTDIR=${D} install-gui