summaryrefslogtreecommitdiff
path: root/app-portage/flaggie/flaggie-0.99.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 17:37:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 17:37:04 +0000
commitcc591ba8d03842768663c67463304ab2a7914563 (patch)
tree03bf0ec1ac6cd20aa0c5b1df92f5a9d2db25e4a3 /app-portage/flaggie/flaggie-0.99.8-r1.ebuild
parent9bb042c828e3fa5ee9340ac4968f11b6f0383cd6 (diff)
app-portage/flaggie : import from Gentoo, make it work with Sisyphus layout (bugfix : https://bugs.redcorelinux.org/show_bug.cgi?id=148)
Diffstat (limited to 'app-portage/flaggie/flaggie-0.99.8-r1.ebuild')
-rw-r--r--app-portage/flaggie/flaggie-0.99.8-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/flaggie/flaggie-0.99.8-r1.ebuild b/app-portage/flaggie/flaggie-0.99.8-r1.ebuild
new file mode 100644
index 00000000..0a52d3da
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.99.8-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="
+ https://github.com/projg2/flaggie/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.5.0[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+PATCHES=(
+ "${FILESDIR}/${P}_sisyphus.patch"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ ewarn "This is a preview release of flaggie 1.x. It it not fully featured"
+ ewarn "yet and it may have significant bugs. Please back your /etc/portage"
+ ewarn "up before using it. Verify the results using --pretend."
+}