summaryrefslogtreecommitdiff
path: root/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2015-01-31 17:29:11 +0200
committerBlackNoxis <steven.darklight@gmail.com>2015-01-31 17:29:11 +0200
commit50fb4d72f0d7941b579276d5e7ba42c6b9db7f2d (patch)
tree578ada51fe66f5b562380e186b41c20dccc46a7f /app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
parent14be2f2eed5153443b51f4fc04072b8fc504a58d (diff)
parent61a9d0efdb629dbf09d1e3287726b19f778088ed (diff)
Merge branch 'master' of github.com:Rogentos/kogaion-desktop
Diffstat (limited to 'app-pda/usbmuxd/usbmuxd-1.1.0.ebuild')
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
new file mode 100644
index 00000000..01c3f93e
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8_p20140530.ebuild,v 1.2 2014/08/03 12:09:08 ssuominen Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils udev user
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+#SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="GPL-2 GPL-3 LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=app-pda/libimobiledevice-1.2.0
+ >=app-pda/libplist-1.11
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ virtual/pkgconfig"
+
+pkg_setup() {
+ enewgroup plugdev
+ enewuser usbmux -1 -1 -1 "usb,plugdev"
+}
+
+src_install() {
+ autotools-utils_src_install udevrulesdir="$(get_udevdir)"/rules.d
+}