summaryrefslogtreecommitdiff
path: root/app-misc/godep/godep-9999.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-11-22 13:39:02 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-11-22 13:39:02 +0200
commit21f0f4c17e9dc3b360f5df22540d06db26e13fb7 (patch)
tree6f8804740cbc17bae18247605f5639e941a613b1 /app-misc/godep/godep-9999.ebuild
parentb2d2dd5f2474e75a999c8f340c07f8bb162cdb4a (diff)
Added go-lang based Syncthing and GoDep. Thanks mva :)
Diffstat (limited to 'app-misc/godep/godep-9999.ebuild')
-rw-r--r--app-misc/godep/godep-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/godep/godep-9999.ebuild b/app-misc/godep/godep-9999.ebuild
new file mode 100644
index 00000000..38ba91da
--- /dev/null
+++ b/app-misc/godep/godep-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit git-r3
+
+RESTRICT="strip"
+
+DESCRIPTION="native bindings for the FUSE kernel module"
+HOMEPAGE="https://github.com/tools/godep"
+EGIT_REPO_URI="https://github.com/tools/${PN}.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-lang/go"
+RDEPEND=""
+
+GO_PN="github.com/tools/${PN}"
+EGIT_CHECKOUT_DIR="${S}/src/${GO_PN}"
+
+export GOPATH="${S}"
+
+src_prepare() {
+ go get ${GO_PN}
+}
+
+src_compile() {
+ go build -v -x -work ${GO_PN} || die
+}
+
+src_install() {
+# go install -v -x -work ${GO_PN} || die
+
+dobin ${S}/bin/godep
+#insinto /usr/lib/go/
+#doins -r "${S}/pkg"
+#insinto /usr/lib/go/src/pkg
+#doins -r "${S}/src/."
+}