summaryrefslogtreecommitdiff
path: root/app-emulation/steam/steam-1.0.0.45.ebuild
diff options
context:
space:
mode:
authorBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
committerBlackNoxis <steven.darklight@gmail.com>2014-02-15 23:24:26 +0200
commit7224c1253228e5c29c78cb3f0f26ce34770f2356 (patch)
tree1684924656132935256e034f35f92abee6623265 /app-emulation/steam/steam-1.0.0.45.ebuild
Added ebuilds for kogaion desktop
Diffstat (limited to 'app-emulation/steam/steam-1.0.0.45.ebuild')
-rw-r--r--app-emulation/steam/steam-1.0.0.45.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/steam/steam-1.0.0.45.ebuild b/app-emulation/steam/steam-1.0.0.45.ebuild
new file mode 100644
index 00000000..6a1e1ba2
--- /dev/null
+++ b/app-emulation/steam/steam-1.0.0.45.ebuild
@@ -0,0 +1,41 @@
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Digital distribution client bootstrap package"
+HOMEPAGE="http://steampowered.com/"
+SRC_URI="http://repo.steampowered.com/${PN}/pool/${PN}/s/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="custom"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+EMUL_X86_VER=20120520
+
+RDEPEND="
+ virtual/ttf-fonts
+ dev-util/desktop-file-utils
+ x11-themes/hicolor-icon-theme
+ net-misc/curl
+ sys-apps/dbus
+ media-libs/freetype
+ x11-libs/gdk-pixbuf
+ gnome-extra/zenity
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-${EMUL_X86_VER}
+ >=app-emulation/emul-linux-x86-soundlibs-${EMUL_X86_VER}
+ >=app-emulation/emul-linux-x86-opengl-${EMUL_X86_VER}
+ )
+ x86? (
+ media-libs/alsa-lib
+ media-libs/mesa
+ x11-libs/libX11
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -rf "${D}"/usr/bin/steamdeps || die # we don't use apt-get
+ dosym /bin/true /usr/bin/steamdeps || die # create blank steamdeps
+}