summaryrefslogtreecommitdiff
path: root/app-admin/vasile/vasile-1.1806.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 14:16:02 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 14:16:02 +0100
commit82938b572b54508ca9e854dcd15af8dcddd4536e (patch)
treea69a0fb76487a1d5d75f2baacf19d64d53e2b80c /app-admin/vasile/vasile-1.1806.ebuild
parent1449b6a16d35b059347655bc386a1da302940595 (diff)
app-admin/vasile : version bump
Diffstat (limited to 'app-admin/vasile/vasile-1.1806.ebuild')
-rw-r--r--app-admin/vasile/vasile-1.1806.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/vasile/vasile-1.1806.ebuild b/app-admin/vasile/vasile-1.1806.ebuild
new file mode 100644
index 00000000..de8d14cf
--- /dev/null
+++ b/app-admin/vasile/vasile-1.1806.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2016-2018 Redcore Linux Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Versatile Advanced Script for ISO and Latest Enchantments"
+HOMEPAGE="https://redcorelinux.org"
+SRC_URI="https://gitlab.com/redcore/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="sys-apps/gentoo-functions"
+RDEPEND="${DEPEND}
+ dev-libs/libisoburn
+ dev-vcs/git
+ sys-boot/grub:2
+ sys-kernel/dkms
+ sys-fs/mtools
+ sys-fs/squashfs-tools"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_install() {
+ default
+ dosym ../../usr/bin/"${PN}".sh usr/bin/"${PN}"
+ dodir var/cache/packages
+ dodir var/cache/distfiles
+}
+
+pkg_postinst() {
+ chown portage:portage /var/cache/distfiles
+ chmod 775 /var/cache/distfiles
+}