summaryrefslogtreecommitdiff
path: root/xfce-extra
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/Manifest.gzbin7558 -> 7558 bytes
-rw-r--r--xfce-extra/xfce4-systemload-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch22
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild60
4 files changed, 84 insertions, 0 deletions
diff --git a/xfce-extra/Manifest.gz b/xfce-extra/Manifest.gz
index 863ccda2bb4c..f996ee0c3551 100644
--- a/xfce-extra/Manifest.gz
+++ b/xfce-extra/Manifest.gz
Binary files differ
diff --git a/xfce-extra/xfce4-systemload-plugin/Manifest b/xfce-extra/xfce4-systemload-plugin/Manifest
index b9fdee6a3626..ca2eaeb762c1 100644
--- a/xfce-extra/xfce4-systemload-plugin/Manifest
+++ b/xfce-extra/xfce4-systemload-plugin/Manifest
@@ -1,3 +1,5 @@
+AUX xfce4-systemload-plugin-1.3.2-x86.patch 742 BLAKE2B 2eca03e4dcb57166efe5f15bba21f37aebc0443bbefdbe6966a7557778464716989e7a7b27817e0353b918068f3050345f509827c16221ea23283e69d3615da0 SHA512 3d7169a7cba2f751a9dbf9c21994227285c692afb3baeaa0f77d2c84d940fddc3bc9bec81ee1509aaca81303bbf3d4ab6dec75aded4f02cfd82300aa635e79e5
DIST xfce4-systemload-plugin-1.3.2.tar.bz2 409767 BLAKE2B 1213c007431318628f4f81026ccdbca2e5b9d34462d66354a1c37999aadc0ef9ed84246bc7f185fd633898364dc0440297dde18288f8beea1d5c7bf6663a6a04 SHA512 f432988f439e5fd7ada16b3e6eaa42b3351531ba3e2b63e2570387bf4d7e605ff9d5a97fde3f5f5eb323ff08aaf3c050f161a5768392b80aa99fabaabda82431
+EBUILD xfce4-systemload-plugin-1.3.2-r1.ebuild 1174 BLAKE2B bf6b38807d72bb61f6c217417163812823f352304f764fb77f46f676aa513cbe3794d4852cf77d8b099d4ca432c903b19445911c5404af18523eb09cfae183b8 SHA512 8a0b86c162418aed1662f890bbdc34ddb91d032d053c72fa18e36231410361f207cc686fa5873138323c848a7efdb52d7ef969aa6a8481a33f94083f2b93c3f3
EBUILD xfce4-systemload-plugin-1.3.2.ebuild 1128 BLAKE2B ebf318ed3e635b3799b4aeb29fd871571c299cf9e954c040361f6ca96d96387706af7a86c4adf1d570bebe0936ca651877fef64b54761b03b00127ec37b3da1f SHA512 392f8ef6e6eed027c7a886923ff9ea13fbcc18599d45cba943b1001ad9ef50014e08fa7dae7b69a9a14440a0d029b87fd6f4490ca669b9b101b446b512043b62
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch
new file mode 100644
index 000000000000..027aea406823
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/files/xfce4-systemload-plugin-1.3.2-x86.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/905084
+https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/-/issues/25
+https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/-/commit/13a2e3ecb4b6cf6aad26c6b1d2388ef6922a5c92
+
+From 13a2e3ecb4b6cf6aad26c6b1d2388ef6922a5c92 Mon Sep 17 00:00:00 2001
+From: Akbarkhon Variskhanov <akbarkhon.variskhanov@gmail.com>
+Date: Tue, 20 Dec 2022 13:50:40 +0500
+Subject: [PATCH] build: Fix failure due to wrong var type (Fixes #25)
+
+--- a/panel-plugin/network.cc
++++ b/panel-plugin/network.cc
+@@ -114,7 +114,7 @@ read_netload_proc (gulong *bytes)
+ gint
+ read_netload (gulong *net, gulong *NTotal)
+ {
+- static guint64 bytes[2];
++ static gulong bytes[2];
+ static gint64 time[2];
+
+ *net = 0;
+--
+GitLab
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..27fc98975a83
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-systemload-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.16:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+ >=xfce-base/xfconf-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-x86.patch
+)
+
+src_configure() {
+ local myconf=(
+ # gtop is needed only as fallback when /proc is not available
+ --disable-libgtop
+ $(use_enable upower)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}