summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
index cf690e000d06..502e2fbc0692 100644
--- a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit xdg-utils
+
DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
@@ -49,3 +51,11 @@ src_install() {
default
find "${D}" -name '*.la' -delete || die
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}