summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild
new file mode 100644
index 000000000000..6b7617bc915b
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-1.7.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl:=
+ x11-libs/gtk+:2=
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:="
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}