summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild
new file mode 100644
index 000000000000..f652fef4599c
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="https://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ ssl? ( >=net-libs/gnutls-2:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf $(use_enable ssl) $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}