summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild')
-rw-r--r--xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild
new file mode 100644
index 000000000000..7aa894a3341e
--- /dev/null
+++ b/xfce-extra/xfce4-eyes-plugin/xfce4-eyes-plugin-4.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in which adds classic eyes to your every step"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-eyes-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.16:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}