summaryrefslogtreecommitdiff
path: root/xfce-base/xfconf/xfconf-4.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfconf/xfconf-4.19.1.ebuild')
-rw-r--r--xfce-base/xfconf/xfconf-4.19.1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/xfce-base/xfconf/xfconf-4.19.1.ebuild b/xfce-base/xfconf/xfconf-4.19.1.ebuild
deleted file mode 100644
index b60487dfb1ba..000000000000
--- a/xfce-base/xfconf/xfconf-4.19.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit bash-completion-r1 vala
-
-DESCRIPTION="A configuration management system for Xfce"
-SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
-HOMEPAGE="
- https://docs.xfce.org/xfce/xfconf/start
- https://gitlab.xfce.org/xfce/xfconf/
-"
-
-LICENSE="GPL-2+"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="debug +introspection vala"
-REQUIRED_USE="vala? ( introspection )"
-
-DEPEND="
- >=dev-libs/glib-2.66.0
- sys-apps/dbus
- >=xfce-base/libxfce4util-4.17.3:=
- introspection? ( >=dev-libs/gobject-introspection-1.66:= )
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-util/gdbus-codegen
- dev-util/glib-utils
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- vala? ( $(vala_depend) )
-"
-
-src_configure() {
- local myconf=(
- $(use_enable introspection)
- $(use_enable vala)
- $(use_enable debug checks)
- --with-bash-completion-dir="$(get_bashcompdir)"
- )
-
- use vala && vala_setup
- econf "${myconf[@]}"
-}
-
-src_test() {
- local service_dir=${HOME}/.local/share/dbus-1/services
- mkdir -p "${service_dir}" || die
- cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
- [D-BUS Service]
- Name=org.xfce.Xfconf
- Exec=${S}/xfconfd/xfconfd
- EOF
-
- (
- # start isolated dbus session bus
- dbus_data=$(dbus-launch --sh-syntax) || exit
- eval "${dbus_data}"
-
- # -j>1 often hangs
- # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
- nonfatal emake -j1 check
- ret=${?}
-
- kill "${DBUS_SESSION_BUS_PID}"
- exit "${ret}"
- ) || die
-}
-
-src_install() {
- default
- find "${D}" -type f -name '*.la' -delete || die
-}