summaryrefslogtreecommitdiff
path: root/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/stumpwm/stumpwm-1.0.0.ebuild')
-rw-r--r--x11-wm/stumpwm/stumpwm-1.0.0.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild b/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
deleted file mode 100644
index ebb4b56c5712..000000000000
--- a/x11-wm/stumpwm/stumpwm-1.0.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit common-lisp-3 autotools elisp-common xdg-utils
-
-DESCRIPTION="Stumpwm is a Window Manager written entirely in Common Lisp."
-HOMEPAGE="https://stumpwm.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="contrib doc emacs clisp ecl +sbcl"
-
-RESTRICT="strip mirror"
-
-RDEPEND="dev-lisp/cl-ppcre
- sbcl? ( >=dev-lisp/sbcl-1.0.32 )
- sbcl? ( >=dev-lisp/clx-0.7.3 )
- !sbcl? ( !clisp? ( !ecl? ( >=dev-lisp/sbcl-1.0.32 ) ) )
- !sbcl? ( !clisp? ( ecl? ( >=dev-lisp/ecls-10.4.1 ) ) )
- !sbcl? ( clisp? ( >=dev-lisp/clisp-2.44[X,new-clx] ) )
- emacs? ( virtual/emacs app-emacs/slime )"
-DEPEND="${RDEPEND}
- sys-apps/texinfo
- doc? ( virtual/texi2dvi )"
-
-PDEPEND="contrib? ( x11-wm/stumpwm-contrib )"
-
-SITEFILE=70${PN}-gentoo.el
-CLPKGDIR="${CLSOURCEROOT}/${CLPACKAGE}"
-
-get_lisp() {
- local lisp
-
- for lisp in "$@" ; do
- use ${lisp} && echo ${lisp} && return
- done
-}
-
-install_docs() {
- local pdffile="${PN}.pdf"
-
- texi2pdf -o "${pdffile}" "${PN}.texi.in" && dodoc "${pdffile}" || die
- cp "${FILESDIR}/README.Gentoo" . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
- dodoc AUTHORS NEWS README.md README.Gentoo
- doinfo "${PN}.info"
- docinto examples ; dodoc sample-stumpwmrc.lisp
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- xdg_environment_reset
- econf --with-lisp=$(get_lisp sbcl clisp ecl)
-}
-
-src_compile() {
- emake -j1
-}
-
-src_install() {
- common-lisp-export-impl-args $(get_lisp sbcl clisp ecl)
- dobin stumpwm
- make_session_desktop StumpWM /usr/bin/stumpwm
-
- common-lisp-install-sources *.lisp
- common-lisp-install-asdf
- # Fix ASDF dir
- sed -i -e "/(:directory/c\ (:directory \"${CLPKGDIR}\")" \
- "${D}${CLPKGDIR}/load-stumpwm.lisp" || die
- use doc && install_docs
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}