summaryrefslogtreecommitdiff
path: root/x11-wm/qtile/qtile-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/qtile/qtile-9999.ebuild')
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index fc96c05526ee..5ba9a0932049 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,15 +34,25 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- x11-base/xorg-server[kdrive]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/xvfbwrapper[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xephyr]
+ x11-apps/xeyes
+ x11-apps/xcalc
+ x11-apps/xclock
)
"
+# display retry backoff slowness and failures
RESTRICT="test"
+PATCHES=( "${FILESDIR}"/${PN}-0.12.0-tests.patch )
+
python_test() {
- VIRTUALX_COMMAND="nosetests" virtualmake
+ # force usage of built module
+ rm -rf "${S}"/libqtile || die
+ PYTHONPATH="${BUILD_DIR}/lib" py.test -v "${S}"/test || die "tests failed under ${EPYTHON}"
}
python_install_all() {