summaryrefslogtreecommitdiff
path: root/x11-wm/openbox/openbox-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/openbox/openbox-9999.ebuild')
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index d753cdef761b..3a35c296e216 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -61,6 +61,8 @@ PATCHES=(
"${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
# https://bugs.gentoo.org/827227
"${FILESDIR}/${PN}-3.6.1-getgrent-to-getgroups.patch"
+ # https://bugs.gentoo.org/901777
+ "${FILESDIR}/${PN}-3.6.1-glib-2.76.patch"
)
pkg_setup() {
@@ -99,9 +101,12 @@ src_configure() {
}
src_install() {
- dodir /etc/X11/Sessions
- echo "/usr/bin/openbox-session" > "${ED}/etc/X11/Sessions/${PN}"
- fperms a+x /etc/X11/Sessions/${PN}
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
+
emake DESTDIR="${D}" install
if use branding; then
insinto /usr/share/themes