summaryrefslogtreecommitdiff
path: root/x11-wm/i3-gaps/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/i3-gaps/files')
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch86
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch71
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.18.2-drop-branch-test.patch11
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.19-fix-docdir.patch22
4 files changed, 33 insertions, 157 deletions
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch
deleted file mode 100644
index 1e67ec2a3c4f..000000000000
--- a/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From: Natanael Copa <ncopa@alpinelinux.org>
-Patch-Source: https://git.alpinelinux.org/cgit/aports/tree/community/i3wm/musl.patch
-Project-Bug-URL: https://github.com/i3/i3/issues/1859
-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=609306
-
-Musl doesn't implement GLOB_TILDE, which is used by i3 when expanding paths.
-
-This patch replaces usage of GLOB_TILDE in glob() by replacing tilde
-with the content of $HOME - if set - manually.
-
-As mentioned in the i3 bugtracker this is an issue that should be solved by musl.
-
-A patch has been sent to musl upstream, but it hasn't been merged yet:
-http://www.openwall.com/lists/musl/2017/01/17/1
----
---- a/i3bar/src/main.c
-+++ b/i3bar/src/main.c
-@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- static char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
---- a/libi3/resolve_tilde.c
-+++ b/libi3/resolve_tilde.c
-@@ -19,28 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strcpy(result, head);
-- if (tail) {
-- strcat(result, tail);
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
- }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch
deleted file mode 100644
index d4f9113e6b15..000000000000
--- a/x11-wm/i3-gaps/files/i3-gaps-4.17-musl.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/i3bar/src/main.c
-+++ b/i3bar/src/main.c
-@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
- *
- */
- static char *expand_path(char *path) {
-- static glob_t globbuf;
-- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
-- ELOG("glob() failed\n");
-- exit(EXIT_FAILURE);
-+ char *home, *expanded;
-+
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
-+ }
- }
-- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
-- globfree(&globbuf);
-- return result;
-+
-+ return sstrdup(path);
- }
-
- void print_usage(char *elf_name) {
---- a/libi3/resolve_tilde.c
-+++ b/libi3/resolve_tilde.c
-@@ -19,28 +19,18 @@
- *
- */
- char *resolve_tilde(const char *path) {
-- static glob_t globbuf;
-- char *head, *tail, *result;
-+ char *home, *expanded;
-
-- tail = strchr(path, '/');
-- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
--
-- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
-- free(head);
-- /* no match, or many wildcard matches are bad */
-- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
-- result = sstrdup(path);
-- else if (res != 0) {
-- err(EXIT_FAILURE, "glob() failed");
-- } else {
-- head = globbuf.gl_pathv[0];
-- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
-- strcpy(result, head);
-- if (tail) {
-- strcat(result, tail);
-+ if (strncmp(path, "~/", 2) == 0) {
-+ home = getenv("HOME");
-+ if (home != NULL) {
-+ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
-+ expanded = scalloc(strlen(home)+strlen(path), 1);
-+ strcpy(expanded, home);
-+ strcat(expanded, path+1);
-+ return expanded;
- }
- }
-- globfree(&globbuf);
-
-- return result;
-+ return sstrdup(path);
- }
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.18.2-drop-branch-test.patch b/x11-wm/i3-gaps/files/i3-gaps-4.18.2-drop-branch-test.patch
new file mode 100644
index 000000000000..f6312fd0bf8f
--- /dev/null
+++ b/x11-wm/i3-gaps/files/i3-gaps-4.18.2-drop-branch-test.patch
@@ -0,0 +1,11 @@
+diff --git a/testcases/t/193-ipc-version.t b/testcases/t/193-ipc-version.t
+index d5f4badf..1f911a63 100644
+--- a/testcases/t/193-ipc-version.t
++++ b/testcases/t/193-ipc-version.t
+@@ -32,6 +32,4 @@ cmp_ok($version->{minor}, '>', 0, 'minor version > 0');
+
+ is(int($version->{minor}), $version->{minor}, 'minor version is an integer');
+ is(int($version->{patch}), $version->{patch}, 'patch version is an integer');
+-like($version->{human_readable}, qr/branch/, 'human readable version contains branch name');
+-
+ done_testing;
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.19-fix-docdir.patch b/x11-wm/i3-gaps/files/i3-gaps-4.19-fix-docdir.patch
new file mode 100644
index 000000000000..6917aa091dff
--- /dev/null
+++ b/x11-wm/i3-gaps/files/i3-gaps-4.19-fix-docdir.patch
@@ -0,0 +1,22 @@
+diff --git a/meson.build b/meson.build
+index 11541e21..a6f8974e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -642,7 +642,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+
+ custom_target(
+@@ -655,7 +655,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+ endif
+