summaryrefslogtreecommitdiff
path: root/x11-wm/goomwwm/goomwwm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/goomwwm/goomwwm-9999.ebuild')
-rw-r--r--x11-wm/goomwwm/goomwwm-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/goomwwm/goomwwm-9999.ebuild b/x11-wm/goomwwm/goomwwm-9999.ebuild
new file mode 100644
index 000000000000..92024280f4e8
--- /dev/null
+++ b/x11-wm/goomwwm/goomwwm-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Get out of my way, Window Manager!"
+HOMEPAGE="https://github.com/seanpringle/goomwwm"
+EGIT_REPO_URI="${HOMEPAGE}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ default
+ sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -DDEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) proto normal
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}