summaryrefslogtreecommitdiff
path: root/x11-wm/fvwm3
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/fvwm3')
-rw-r--r--x11-wm/fvwm3/Manifest3
-rw-r--r--x11-wm/fvwm3/fvwm3-1.0.7-r1.ebuild168
-rw-r--r--x11-wm/fvwm3/fvwm3-9999.ebuild8
3 files changed, 175 insertions, 4 deletions
diff --git a/x11-wm/fvwm3/Manifest b/x11-wm/fvwm3/Manifest
index 2d6c6c22cd09..934fb20ab33e 100644
--- a/x11-wm/fvwm3/Manifest
+++ b/x11-wm/fvwm3/Manifest
@@ -6,6 +6,7 @@ DIST fvwm3-1.0.6a.tar.gz 4538100 BLAKE2B c71087eb09a17760ff5754060c4639228f268a0
DIST fvwm3-1.0.7.tar.gz 4512128 BLAKE2B 9e7363355f3d3221dc72175c6ff449a476a32020248dc580c4b73687759c49b255bab8b7e29440fa1473153459ef984369e88d331a0b55154114e3c901867003 SHA512 91973abb7b3f79cec4fba28d9aa071923aa975eae3f3e00257e8633e2d376732cd5db7e42a4330bc849f807fc149abfbeef6100fe2ca6c05c847b61ee48236ed
EBUILD fvwm3-1.0.4-r2.ebuild 4319 BLAKE2B d9b573097a3b1c37c57ac223e0c659942a17c4e3a326e31292e16a3f9a0bb950949dfcb83402fad01650f89f984d55df09c8f1f88a05a1d952c7cc0275c62dc0 SHA512 5e912a106b192b0e550a22ebaa43229a5637d2d5a89fa4e10f16ad4963e31484b63f663465395aaae07f27aea6cea048c869d5cf13104568b9e7d18d7671c563
EBUILD fvwm3-1.0.6a.ebuild 4191 BLAKE2B 52523d243ba77d83afb5bacfb1900da1cc5061f2de320821eb7b475666a3fc312c871ea9e6e5156a74f6623df6612a46eb6afd4be42cffdd69d964886e442754 SHA512 b922f6cc11fbcf2d99682a22cf255a1cee075d44d6f2b9fe1210472a8227faadfd0c723b1eb23639b255f27be878e520b81ad3b0a30ee037c453130c4a243464
+EBUILD fvwm3-1.0.7-r1.ebuild 4026 BLAKE2B c895417abd60e31a9825212abace2b99c5d722907b89df018b49fda799b4e4a2a08ba25257a8bcaa08cf105cde6712063b6735e85d04fa78208ee23edca254f8 SHA512 b926a9cee00bc5717d1719401372e9cf820e6425e799758c85b7c19187f909440cf4e09ba6c7292cbca2107351db5bbecaf5f316915db2d49ebe1e06ed0e6ab9
EBUILD fvwm3-1.0.7.ebuild 4086 BLAKE2B 7ce04ec9790868aab796ae10cb98e210ebec99645b6619dd11a8895b032fb9999aa62c056e327124e1c462c36e668bc3f7916e25aa5e9a38a2b5a52f98bc0c17 SHA512 8b094daa7873630b0b674553b4cda292aa06f99db9ea66d6e57cc082bb4a87a46ddafa23c5d85ed066565a7f9084a890390bd8c72a3d61782bea0f323b8f579e
-EBUILD fvwm3-9999.ebuild 4086 BLAKE2B 7ce04ec9790868aab796ae10cb98e210ebec99645b6619dd11a8895b032fb9999aa62c056e327124e1c462c36e668bc3f7916e25aa5e9a38a2b5a52f98bc0c17 SHA512 8b094daa7873630b0b674553b4cda292aa06f99db9ea66d6e57cc082bb4a87a46ddafa23c5d85ed066565a7f9084a890390bd8c72a3d61782bea0f323b8f579e
+EBUILD fvwm3-9999.ebuild 4026 BLAKE2B c895417abd60e31a9825212abace2b99c5d722907b89df018b49fda799b4e4a2a08ba25257a8bcaa08cf105cde6712063b6735e85d04fa78208ee23edca254f8 SHA512 b926a9cee00bc5717d1719401372e9cf820e6425e799758c85b7c19187f909440cf4e09ba6c7292cbca2107351db5bbecaf5f316915db2d49ebe1e06ed0e6ab9
MISC metadata.xml 1167 BLAKE2B 9298a152a101f678f0aac744cd1348302dae392e2fa6d37aaf4616f368d6bb96e09a01aa50700bc59672fa5710ebcf5f49911e6bf2205bd6f157d50fb831741d SHA512 90bde9731cc4b0147dbe9072c634bafce51ec5b33e636e16ab19b81538863ab9c103ed40b0b97042a9c11a01e68c3c81ffb1be542909bf145a16a52ce8c6f396
diff --git a/x11-wm/fvwm3/fvwm3-1.0.7-r1.ebuild b/x11-wm/fvwm3/fvwm3-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..897728504f51
--- /dev/null
+++ b/x11-wm/fvwm3/fvwm3-1.0.7-r1.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+GO_OPTIONAL=1
+inherit autotools desktop flag-o-matic go-module python-single-r1 toolchain-funcs
+
+DESCRIPTION="A multiple large virtual desktop window manager derived from fvwm"
+HOMEPAGE="https://www.fvwm.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fvwmorg/fvwm3.git"
+ EGIT_BRANCH="main"
+else
+ SRC_URI="https://github.com/fvwmorg/fvwm3/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~riscv"
+fi
+
+LICENSE="GPL-2+ FVWM
+ go? ( Apache-2.0 BSD MIT )"
+SLOT="0"
+IUSE="bidi debug doc +go netpbm nls perl readline stroke svg tk lock"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}"
+
+DOCS=( NEWS )
+
+if [[ ${PV} == 9999 ]]; then
+ DOCS+=(
+ dev-docs/COMMANDS
+ dev-docs/DEVELOPERS.md
+ dev-docs/INSTALL.md
+ dev-docs/PARSING.md
+ dev-docs/TODO.md
+ dev-docs/NEW-COMMANDS.md
+ )
+fi
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-libs/libxslt
+ dev-ruby/asciidoctor )
+ app-arch/unzip
+ go? ( >=dev-lang/go-1.14 )
+"
+
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ !x11-wm/fvwm
+ dev-lang/perl
+ dev-libs/glib:2
+ dev-libs/libevent:=
+ media-libs/fontconfig
+ media-libs/libpng:=
+ sys-apps/debianutils
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ bidi? ( dev-libs/fribidi )
+ lock? ( x11-misc/xlockmore )
+ netpbm? ( media-libs/netpbm )
+ perl? ( tk? (
+ dev-lang/tk
+ dev-perl/Tk
+ >=dev-perl/X11-Protocol-0.56
+ )
+ )
+ readline? (
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ )
+ stroke? ( dev-libs/libstroke )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ use go && ( sed -e 's/GOFLAGS=-ldflags="-s -w"/GOFLAGS=/' \
+ -i bin/FvwmPrompt/Makefile.am || die )
+
+ eautoreconf
+}
+
+src_configure() {
+ # Non-upstream email where bugs should be sent; used in fvwm-bug.
+ export FVWM_BUGADDR="desktop-wm@nogentoo.org"
+
+ # Recommended by upstream for release. Doesn't really matter for live ebuilds.
+ append-flags -fno-strict-aliasing
+
+ # Signed chars are required.
+ for arch in arm arm64 ppc ppc64; do
+ use $arch && append-flags -fsigned-chars
+ done
+
+ local myconf=(
+ --with-imagepath=/usr/include/X11/bitmaps:/usr/include/X11/pixmaps:/usr/share/icons/fvwm
+ --enable-package-subdirs
+ $(use_enable bidi)
+ $(use_enable doc mandoc)
+ $(use_enable go golang)
+ $(use_enable nls)
+ $(use_enable nls iconv)
+ $(use_enable perl perllib)
+ $(use_with readline readline-library)
+ $(use_enable svg rsvg)
+ --enable-png
+ )
+
+ use readline && myconf+=( --without-termcap-library )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" emake AR="$(tc-getAR)"
+ if [[ ${PV} == *9999 ]]; then
+ use doc && emake -C doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${ED}" prefix="/usr" exec_prefix="/usr" datarootdir="/usr/share" install
+
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
+
+ python_scriptinto "/usr/bin"
+ python_doscript "${ED}/usr/bin/FvwmCommand" "${ED}/usr/bin/fvwm-menu-desktop"
+ einstalldocs
+
+ make_session_desktop fvwm3 /usr/bin/fvwm3
+}
+
+pkg_postinst() {
+ if use go; then
+ ewarn "FvwmPrompt has been installed, it provides the functionality of both FvwmCommand and FvwmConsole."
+ ewarn "For compatibility with the existing fvwm2 configurations, the ebuild will install a FvwmCommand wrapper."
+ ewarn "If you need FvwmConsole, install ${PN} with USE=\"-go\";"
+ ewarn "however FvwmPrompt and FvwmCommand will not be installed."
+ else
+ ewarn "FvwmConsole has been installed, but FvwmCommand and FvwmPrompt are no longer included in this ebuild."
+ ewarn "If you need FvwmPrompt or FvwmCommand, install ${PN} with USE=\"go\"."
+ ewarn "In that case, FvwmPrompt will replace FvwmConsole and provide the same functionality in a more flexible way."
+ fi
+}
diff --git a/x11-wm/fvwm3/fvwm3-9999.ebuild b/x11-wm/fvwm3/fvwm3-9999.ebuild
index 46cdabe5b388..897728504f51 100644
--- a/x11-wm/fvwm3/fvwm3-9999.ebuild
+++ b/x11-wm/fvwm3/fvwm3-9999.ebuild
@@ -141,9 +141,11 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" prefix="/usr" exec_prefix="/usr" datarootdir="/usr/share" install
- dodir /etc/X11/Sessions
- echo "/usr/bin/fvwm3" > "${ED}/etc/X11/Sessions/${PN}" || die
- fperms a+x "/etc/X11/Sessions/${PN}" || die
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
python_scriptinto "/usr/bin"
python_doscript "${ED}/usr/bin/FvwmCommand" "${ED}/usr/bin/fvwm-menu-desktop"