summaryrefslogtreecommitdiff
path: root/x11-wm/blackbox
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/Manifest3
-rw-r--r--x11-wm/blackbox/blackbox-0.77.ebuild4
-rw-r--r--x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch35
3 files changed, 41 insertions, 1 deletions
diff --git a/x11-wm/blackbox/Manifest b/x11-wm/blackbox/Manifest
index a1c467ae67d8..43006330c473 100644
--- a/x11-wm/blackbox/Manifest
+++ b/x11-wm/blackbox/Manifest
@@ -1,4 +1,5 @@
+AUX blackbox-0.77-gcc12-time.patch 1096 BLAKE2B 4a2660814d6bcc06c1f49dce6c36cba9a31ad8ce79464aa37ab2954f1634d926454e682332d9e4d9a60927da77fbb60b3166d498481334cd6725100cdbf20253 SHA512 346ae37fb8a9535c4e4fab24c81b70e0be93584ab2995ed290e3e79915239b4f24d34fe67db42bb68a00651148b2e3d64c15760d2fec3867fe56e3cdff5e292b
AUX blackbox.desktop 128 BLAKE2B 3acb8eec34024ad4b5625d76f16206e40cceb11db194a084ba90b160e54824f95f228999128efe76c7c11509e89e85a2e2fa49f0f00f43777a7f65c0afe2ec01 SHA512 340bf82fdfe40fabe698b0fe9ce371395ab82a0570323663a2d1c3f26a36a2b1628dd91fe691a58d22b599f4cde060a005accc7294b9758cc4220d92f226d28d
DIST blackbox-0.77.tar.gz 394176 BLAKE2B c52872fd02eba6857d2a3f5a8e122a6a8a0cdaa9c2d83f5b2510f9e770e650626d07f6d2b43b18bc3d77de4bfefc9bb9fb10321de0e72d4f82e5988f3c670d59 SHA512 d1f86707d9a2acb68db6a9af947e47acfd687752d06e3e2a60932550fbfa087730e6890b6ceb086f8aa8cf04e932ed7864f92266368fc43dc70b4b58140a792d
-EBUILD blackbox-0.77.ebuild 1349 BLAKE2B 5ffe3a6e3da61b87c4c5e7b579cf4e4d51be454ba62d05dc17566a4a8d1bbdea197454b7445bff1355214fb4c03865f662090113e2b92ca1adc372f0a0fe4e61 SHA512 85a80f6e81227fdc8b183c1a313d89ddf4a08208c3714eb6bdfaae18ea6824a4b7c06754598e5b625a2c80ef58c42a91097c0c09664c7194c5c25217ecb2dacb
+EBUILD blackbox-0.77.ebuild 1405 BLAKE2B 5809b4f1a9b01efb258cdafb5a4105935b0a9aa735341761a190a1630ab4a432eca1d93d78964922608d59e7e2559132c69d21f60c4f7ad6587df4d42be8d093 SHA512 a32dd4aa1f960851c0e35aec6bb56b10a3591566cf0765f13f5d9d3ac662555df35b797d877943be4febae0b5607d1b89b74a6cd48783dd6f94d12259bd0ee80
MISC metadata.xml 573 BLAKE2B a267119a25e9f1ea39b05b705a9b186f428b5723f7d8abf43f55561f6929d5e0c1800aed851c81c2b6ddc655974848f43fd79426fc4907a77da0fccf571c2556 SHA512 0dabe8daa4a79b684c1654722ac9d7f958d4511046a7d2a28bd2500751695621bbf4043579f08f73ad98745c921e766b0f19112995324e31e3bf9efa78df221a
diff --git a/x11-wm/blackbox/blackbox-0.77.ebuild b/x11-wm/blackbox/blackbox-0.77.ebuild
index 815969ba46db..32b54c5b3e31 100644
--- a/x11-wm/blackbox/blackbox-0.77.ebuild
+++ b/x11-wm/blackbox/blackbox-0.77.ebuild
@@ -26,6 +26,10 @@ BDEPEND=">=sys-devel/autoconf-2.71
S="${WORKDIR}"/blackboxwm-${PV}
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.77-gcc12-time.patch
+)
+
src_prepare() {
sed -e '/AC_DISABLE_SHARED/d' -i configure.ac || die
default
diff --git a/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch b/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch
new file mode 100644
index 000000000000..196e3878253d
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.77-gcc12-time.patch
@@ -0,0 +1,35 @@
+https://github.com/bbidulock/blackboxwm/pull/42
+
+From d3481ee7b7d104ef53ead4d35b9a9254c64bb87a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 12 Jun 2022 20:49:09 +0100
+Subject: [PATCH] Fix build with GCC 12 (missing <time.h> include)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes build failure with GCC 12:
+```
+Toolbar.cc: In member function ‘void Toolbar::reconfigure()’:
+Toolbar.cc:260:17: error: ‘time’ was not declared in this scope; did you mean ‘Time’?
+ 260 | time_t ttmp = time(NULL);
+ | ^~~~
+ | Time
+Toolbar.cc:265:21: error: ‘localtime’ was not declared in this scope; did you mean ‘clock_timer’?
+ 265 | struct tm *tt = localtime(&ttmp);
+ | ^~~~~~~~~
+ | clock_timer
+```
+
+Bug: https://bugs.gentoo.org/851603
+--- a/src/Toolbar.cc
++++ b/src/Toolbar.cc
+@@ -38,6 +38,7 @@
+ #include <X11/Xutil.h>
+ #include <sys/time.h>
+ #include <assert.h>
++#include <time.h>
+
+
+ long nextTimeout(int resolution)
+