summaryrefslogtreecommitdiff
path: root/x11-themes/vdr-channel-logos
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/vdr-channel-logos')
-rw-r--r--x11-themes/vdr-channel-logos/Manifest4
-rw-r--r--x11-themes/vdr-channel-logos/metadata.xml4
-rw-r--r--x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r2.ebuild (renamed from x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild)18
3 files changed, 20 insertions, 6 deletions
diff --git a/x11-themes/vdr-channel-logos/Manifest b/x11-themes/vdr-channel-logos/Manifest
index d14d84623c95..c4d2357864b8 100644
--- a/x11-themes/vdr-channel-logos/Manifest
+++ b/x11-themes/vdr-channel-logos/Manifest
@@ -1,4 +1,4 @@
DIST logos-0.2.tar.gz 659476 BLAKE2B ed882e950fb5d1a8c1fea6194dc5311c43f68f92d25cb2e2b9298c2ef86ec165f30217b58f470cbc81d8122cedd1fa8441f6ab7249a448e3160f5d0c4f797810 SHA512 27b961a9c4da2e3d11e932f0ed69e85f5cac5e06666b1cff116cae483a32ab45c794ebb225900153745cb75ae51d211dbdb5a8dafb28997a5420859dd8ef55ad
-EBUILD vdr-channel-logos-0.2-r1.ebuild 654 BLAKE2B 2547ebf38b5a6bb5df72f440109cdbb05b75abf0b1773407319a86b03b3acba477749e9bcf3039f0f88f9c88b7ba6a0d723b0d88deaff2ec3fc0603b6952da42 SHA512 f1184ba8b7312057d09a6bde7166a45e92047bcac619e8d03d3eecd281a6b65e8fe8a2e664398cf6ffde0b55ac79a686d524b0c612cab06cf84e30b7339ad510
+EBUILD vdr-channel-logos-0.2-r2.ebuild 854 BLAKE2B f821c2891561a014b246036b459ae215109705764cd1d89afc26f708eabf87d94e768cef680eddebfa226503477269d9c675825c49e2b4ec370876ac89740fc6 SHA512 40e87afb419c81fff097e1b0f3d0cc328a61c259deda43fe92ec139f5f103377ff4f260770a27d50b04d2e4ba5eb1db8fea1e5ff7e45a26780128955ef531b63
EBUILD vdr-channel-logos-0.2.ebuild 544 BLAKE2B ce3f3ae3048b889ff6959fca03af9d7298544cea927c4ed4678bec1f396acebc3b342ed0446df011be759af9842f121e89fb7f19aef7be2aba21edfc0a96f89b SHA512 b51d52c716a1c4d411ce68408ebf7c8628135f942ced4968cb15f539ba478ff6c6532994f8a9ff4f4b5eb22970192d77f9b42dea5813db0d3aade90fb1c84297
-MISC metadata.xml 249 BLAKE2B d4dad5b7d4d1bbb3887888fd8519955b5e1262b2f3af04802d69aef6d836bf8d87d0316d9d3527d3a98c8c8ff98cf61d474bdc4ddbb3873592bae7fbfd9f4551 SHA512 b6440069f895b4d5360dec283faef3b6d3b3d65e7b895d8f8bcc2c7106d19db75ebede53ca8e0e67adf63af73ed54ca4efbc1c58b317dbfa27ed2050e175bde3
+MISC metadata.xml 362 BLAKE2B adf483a7a510a8722e3f2a466c6cd79412ae0c87835a1dc29ff866ccaa43822ea8746ab699e5c3513e9aca22c183857f5918437fa20ac171e06a69b6112158ca SHA512 5e450b3909bef6baa28baae73ed91476826137a8b2f244d5543f4b428bcca42d1bfa52bd32cbca3df3abd4b2fc45175ac78adb786c01b8b604f54a3b5a6633f1
diff --git a/x11-themes/vdr-channel-logos/metadata.xml b/x11-themes/vdr-channel-logos/metadata.xml
index 984a01fab265..19717edee843 100644
--- a/x11-themes/vdr-channel-logos/metadata.xml
+++ b/x11-themes/vdr-channel-logos/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>hd_brummy@gentoo.org</email>
+ <name>Joerg Bornkessel</name>
+ </maintainer>
<maintainer type="project">
<email>vdr@gentoo.org</email>
<name>Gentoo VDR Project</name>
diff --git a/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild b/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r2.ebuild
index 17184e4f08e4..7baf764c285f 100644
--- a/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild
+++ b/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r2.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
MY_P=${PN#vdr-channel-}-${PV}
@@ -18,9 +16,21 @@ IUSE=""
S=${WORKDIR}/logos
-RDEPEND="app-text/convmv"
+BDEPEND="app-text/convmv"
+
+_test_charmap() {
+ local charmap=$(locale charmap)
+
+ if [ "${charmap}" != "UTF-8" ]; then
+ eerror "You need locale UTF-8 to use the logos"
+ die "missing locale UTF-8 on your system"
+ fi
+}
src_prepare() {
+ default
+
+ _test_charmap
convmv --notest --replace -f iso-8859-1 -t utf-8 -r "${S}"/
}