summaryrefslogtreecommitdiff
path: root/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild')
-rw-r--r--x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild41
1 files changed, 19 insertions, 22 deletions
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild
index c4913359517a..74c2e45634cf 100644
--- a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild
+++ b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit gnome2-utils
+EAPI=7
+
+inherit xdg
DESCRIPTION="SVG and PNG icon theme from the Tango project"
HOMEPAGE="http://tango.freedesktop.org"
@@ -12,31 +13,31 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="minimal png"
+RESTRICT="binchecks strip"
RDEPEND="!hppa? ( !minimal? ( x11-themes/adwaita-icon-theme ) )
>=x11-themes/hicolor-icon-theme-0.12"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-util/intltool
- virtual/pkgconfig
- >=gnome-base/librsvg-2.34
- virtual/imagemagick-tools[png?]
+ gnome-base/librsvg
sys-devel/gettext
- >=x11-misc/icon-naming-utils-0.8.90"
-
-RESTRICT="binchecks strip"
+ virtual/imagemagick-tools[png?]
+ virtual/pkgconfig
+ x11-misc/icon-naming-utils"
-DOCS="AUTHORS ChangeLog README"
+PATCHES=(
+ # https://bugs.gentoo.org/413183
+ "${FILESDIR}"/${PN}-0.8.90-rsvg-convert.patch
+)
src_prepare() {
- sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure || die #413183
+ xdg_src_prepare
# https://bugs.gentoo.org/472766
- shopt -s nullglob
- cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
- if test -n "${cards}"; then
- addpredict "${cards}"
- fi
- shopt -u nullglob
+ local d
+ for d in /dev/dri/card*; do
+ [[ -s ${d} ]] && addpredict "${d}"
+ done
}
src_configure() {
@@ -49,7 +50,3 @@ src_install() {
addwrite /root/.gnome2
default
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }