summaryrefslogtreecommitdiff
path: root/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild')
-rw-r--r--x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
index 359cd9fad71b..102e33b7dc4b 100644
--- a/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
+++ b/x11-themes/tango-icon-theme-extras/tango-icon-theme-extras-0.1.0-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils gnome2-utils
+EAPI=7
+
+inherit autotools xdg
DESCRIPTION="Tango icons for iPod Digital Audio Player devices and the Dell Pocket DJ DAP"
HOMEPAGE="http://tango.freedesktop.org"
@@ -12,22 +13,20 @@ LICENSE="CC-BY-SA-2.5"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="png"
+RESTRICT="binchecks strip"
-RDEPEND=">=x11-themes/tango-icon-theme-0.8.90"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=gnome-base/librsvg-2.34
+RDEPEND="x11-themes/tango-icon-theme"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gnome-base/librsvg
virtual/imagemagick-tools[png?]
- >=x11-misc/icon-naming-utils-0.8.90"
-
-RESTRICT="binchecks strip"
+ virtual/pkgconfig
+ x11-misc/icon-naming-utils"
-DOCS="AUTHORS ChangeLog NEWS README"
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-graphicsmagick.patch
- epatch "${FILESDIR}"/${P}-MKDIR_P.patch
- sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure{,.ac} || die #413183
+ xdg_src_prepare
eautoreconf
}
@@ -36,7 +35,3 @@ src_configure() {
$(use_enable png png-creation) \
$(use_enable png icon-framing)
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }