summaryrefslogtreecommitdiff
path: root/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild')
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild
index deac2e20f0e3..c10ba3f64989 100644
--- a/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_ECLASS=cmake
MY_PN=${PN}2
MY_P=${MY_PN}-${PV}
inherit cmake-multilib
@@ -11,13 +10,12 @@ inherit cmake-multilib
DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
HOMEPAGE="https://store.kde.org/p/1005553/"
SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ~ppc x86"
SLOT="2"
-IUSE="debug"
+KEYWORDS="amd64 ~ppc x86"
-BDEPEND="virtual/pkgconfig"
DEPEND="
dev-libs/dbus-glib[${MULTILIB_USEDEP}]
dev-libs/glib:2[${MULTILIB_USEDEP}]
@@ -30,6 +28,7 @@ DEPEND="
RDEPEND="${DEPEND}
!x11-themes/oxygen-gtk:0
"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${P}-xul.patch"
@@ -40,8 +39,6 @@ PATCHES=(
"${FILESDIR}/${P}-tabstyle.patch"
)
-S=${WORKDIR}/${MY_P}
-
multilib_src_configure() {
if ! multilib_is_native_abi; then
local mycmakeargs=(