summaryrefslogtreecommitdiff
path: root/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild')
-rw-r--r--x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild b/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild
new file mode 100644
index 000000000000..ff55f66764e3
--- /dev/null
+++ b/x11-themes/mate-icon-theme/mate-icon-theme-1.28.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE default icon themes"
+LICENSE="GPL-2"
+SLOT="0"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+RESTRICT="binchecks strip"
+
+src_configure() {
+ mate_src_configure --enable-icon-mapping
+}