summaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild')
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild40
1 files changed, 25 insertions, 15 deletions
diff --git a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
index 94c86304a7f1..7ac97c44e10f 100644
--- a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
+++ b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
@@ -1,34 +1,43 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
PATCH_LEVEL=12
MY_PN=${PN/gtk-engines-}
DESCRIPTION="A derivative of the standard Clearlooks GTK+ 2.x engine with more orange feel"
HOMEPAGE="http://packages.ubuntu.com/search?keywords=gtk2-engines-ubuntulooks"
-SRC_URI="mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz
+SRC_URI="
+ mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz
mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}-${PATCH_LEVEL}.diff.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE=""
-RDEPEND=">=dev-libs/glib-2
+RDEPEND="
+ dev-libs/glib:2
x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
S=${WORKDIR}/${MY_PN}-${PV}
-src_prepare() {
- epatch "${WORKDIR}"/${MY_PN}_${PV}-${PATCH_LEVEL}.diff
- EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch debian/patches
- epatch "${FILESDIR}"/${P}-glib-2.31.patch #419395
+PATCHES=(
+ "${WORKDIR}"/${MY_PN}_${PV}-${PATCH_LEVEL}.diff
+ "${S}"/debian/patches/01_fix_listview_arrows_drawing.patch
+ "${S}"/debian/patches/01_fix_tick_box_drawing.patch
+ "${S}"/debian/patches/01_progressbar-fix.patch
+ "${S}"/debian/patches/02_fix-firefox-buttons.patch
+ # https://bugs.gentoo.org/419395
+ "${FILESDIR}"/${P}-glib-2.31.patch
+)
+src_prepare() {
+ default
eautoreconf # update libtool for interix
}
@@ -37,8 +46,9 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README
+ default
newdoc debian/changelog ChangeLog.debian
- find "${ED}"/usr -name '*.la' -type f -exec rm -f {} +
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}