summaryrefslogtreecommitdiff
path: root/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild')
-rw-r--r--x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
index 7939398070e6..e4b5163588bd 100644
--- a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
+++ b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils gnome2-utils
+EAPI=7
+
+inherit gnome2-utils
DESCRIPTION="A massively improved variant of the well-known Gartoon theme"
HOMEPAGE="https://gnome-look.org/content/show.php/?content=74841"
@@ -12,7 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="
+BDEPEND="
dev-lang/perl
dev-perl/Switch
gnome-base/librsvg
@@ -20,9 +21,9 @@ DEPEND="
RESTRICT="binchecks strip"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
+)
src_configure() {
# perl script, not autotools based
@@ -40,6 +41,14 @@ src_install() {
dodoc AUTHORS changelog README TODO
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}