summaryrefslogtreecommitdiff
path: root/x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild')
-rw-r--r--x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild b/x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild
index 45ae2d79b317..8ed5ccc37dce 100644
--- a/x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild
+++ b/x11-themes/fvwm-themes/fvwm-themes-0.7.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="A configuration framework for the fvwm window manager"
HOMEPAGE="http://fvwm-themes.sourceforge.net/"
@@ -17,14 +17,11 @@ RDEPEND=">=x11-wm/fvwm-2.6.2"
DEPEND="${RDEPEND}
gnome? ( virtual/imagemagick-tools )"
-PATCHES=(
- "${FILESDIR}/${P}-gentoo.patch"
- "${FILESDIR}/${P}-posix-sort.patch"
-)
-
src_prepare() {
- default
- mv configure.in configure.ac || die "moving configure.in failed"
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-posix-sort.patch
+
eautoreconf
}
@@ -32,6 +29,11 @@ src_configure() {
econf $(use_enable gnome gnome-icons)
}
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
pkg_postinst() {
fvwm-themes-config --site --reset
fvwm-themes-menuapp --site --build-menus --remove-popup