summaryrefslogtreecommitdiff
path: root/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
new file mode 100644
index 000000000000..475205e3eceb
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtwidgets:5=
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ INSTALL_ROOT="${D}" default
+}