summaryrefslogtreecommitdiff
path: root/x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild')
-rw-r--r--x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild
new file mode 100644
index 000000000000..ae596a5c9330
--- /dev/null
+++ b/x11-themes/QGnomePlatform/QGnomePlatform-0.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/MartinBriza/QGnomePlatform"
+SRC_URI="https://github.com/MartinBriza/QGnomePlatform/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtwidgets:5=
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}