summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/Manifest.gzbin4558 -> 4554 bytes
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.27.0.ebuild37
-rw-r--r--x11-terms/kitty-terminfo/Manifest2
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild23
-rw-r--r--x11-terms/kitty/Manifest6
-rw-r--r--x11-terms/kitty/kitty-0.27.0.ebuild156
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild22
8 files changed, 239 insertions, 9 deletions
diff --git a/x11-terms/Manifest.gz b/x11-terms/Manifest.gz
index 36f947db36ca..99b4c80ec15f 100644
--- a/x11-terms/Manifest.gz
+++ b/x11-terms/Manifest.gz
Binary files differ
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 3d34c6ab2311..dfe9ffacfca2 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
+DIST kitty-0.27.0.tar.xz 5067860 BLAKE2B 5c9126dd9e76afcd6d53aa025adc36912145129b16b0db60c9cb12736df895166d417cbce9198e1feddd3f07c216e557136a130853fa0ddd91833c67fe236c4e SHA512 8063008df261747a7089c69ad9ae3a3d3c24286014f02d04faee9f0b5b6f452172cf99ff8a520ca8e314ba0009e0009701292656db913c23d84b6a2311085813
EBUILD kitty-shell-integration-0.26.5.ebuild 1483 BLAKE2B 8bb6bf5cbd3a11f5773f1783b5d6e8ed5bdac200a61e6df7326913081280f0e334b7c100cb09df05b6a3e99682fbb63117622671184b2cc2f12b87f975c345a0 SHA512 b032be5bdada3925e23bf44ad466b4aa1b51905715c6d5fef0781aeb634f1b728ad1429f75e4fcf8abffc6b88c975d73079037d32f909dfd91b38c8802095e04
+EBUILD kitty-shell-integration-0.27.0.ebuild 1490 BLAKE2B c8433392f5846e1a21ba675142e152ad00fe1bddcf49ed4eb17f1e0c4684f3ae447f3175f4392611a7205efba7ce081115bd4c11372e5005f7524350923d89b9 SHA512 84c824f5c411e3e768e70cfb86d871145d5466c4a7cbb1e6717a00289066037c692864eaf76ec1d9e4610a85fad25a31d6b65ebbd74741c893278c77eb8e1498
EBUILD kitty-shell-integration-9999.ebuild 1403 BLAKE2B 9f1e4aebc1103678d42ba5809c41848b2ace36e2ed0137bdb0f30048cb4372c61f80e509a8087a52b149fe25115ca8aaa511d4697459e1087bee65788055dd85 SHA512 d7674435c3d3d9cfd04d47889f9e0f1cb4e60a6dc3506529829b3782e958fc3cb18fe8b0a25463725128106d6ca8308a17ae961b184e13682a1b05852e22ce4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.27.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.27.0.ebuild
new file mode 100644
index 000000000000..b39d00301084
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.27.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 03043a161fac..4416216e0e2f 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
+DIST kitty-0.27.0.tar.xz 5067860 BLAKE2B 5c9126dd9e76afcd6d53aa025adc36912145129b16b0db60c9cb12736df895166d417cbce9198e1feddd3f07c216e557136a130853fa0ddd91833c67fe236c4e SHA512 8063008df261747a7089c69ad9ae3a3d3c24286014f02d04faee9f0b5b6f452172cf99ff8a520ca8e314ba0009e0009701292656db913c23d84b6a2311085813
EBUILD kitty-terminfo-0.26.5.ebuild 625 BLAKE2B bd4f3df430b79ca1ad20d73d65969a1ddc8a2f2ebbc38a88c9c9f3658b8baaabf7046f9d6cadbf77e8d131ebc1b8ee30e9615df32b70d09ffbf58ea506fc993f SHA512 a21aec302968475896ab9e1621aeba6f6da4c154c89139e4936609bbddba7f1bd8058fdf0daa6faae436b45d6eb9438390d925f12c87669f6b6929083a50e4d9
+EBUILD kitty-terminfo-0.27.0.ebuild 627 BLAKE2B f3b3c4f1986562cce80f739e6f50be933fab5f8983979a566f4a34f3cbc7dae7be9916f6d49256275a612dbc50bd25cd4197680adfb871427c2bc5a01c3243ad SHA512 4785b7936652569a987236f69ccf1146b9d3e7722d752f0cb49eec39d563d9633227ec51c1cdaf77401d1ea2d14527e5b418a111e74212d1d050f1a266293ca0
EBUILD kitty-terminfo-9999.ebuild 545 BLAKE2B 50bf783694580b016f3291640d6c4ab3e8ee335f78d13b75cb7ebe6628ddd2f244fab2e7c465a3964ed6b5e0ebbdb144c739a01ffa7239c8518503ea107a52f2 SHA512 267b8b4a526ee22159f7c1c0d9a089e183308e1e7f61d775834e4ed5d4f25be7aac8cc3db4afa3c3f1e933159f27abff25c31989dd6478c1727eec590bf0a3c8
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild
new file mode 100644
index 000000000000..f29634123585
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.27.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 328af9e5ed20..bbcc1a4a9fdf 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,5 +1,9 @@
DIST kitty-0.26.5.tar.xz 4749988 BLAKE2B 488969b4d7c6aed489a540a8e3bee183345fcfb7e05ae5604f4af40f0720ed931cff82cf389e2fa4015eed74762c0630481a99eeb9302c22c89c4f3e247170d4 SHA512 086ae03d0e382afbe3001e357ef51388c7a8e81fa5b4bf9ce8b123a7fc8bfff3bd68d074e926f540a1f2b83062baa831e44d29c017cabfe8221bebe49b64e808
DIST kitty-0.26.5.tar.xz.sig 566 BLAKE2B 377202d46e66854e0cf1998506e0fafca54b33d85264e47c13aa4b98d272c786809375f1e277ec169291e06809f11b5b061ec1243a708711fa2350243ad1eca2 SHA512 0c691d8becff2b0f24e09b941d7315efaac831beacfed6f66b9186bde9c502f2ae86289f4b0d8fa6a34624dce7a1e958ba2d0502fd87003ba08b07fa07c6ae17
+DIST kitty-0.27.0-vendor.tar.xz 696348 BLAKE2B cc20c2dec531907d50f796d2ee61e1468b66f02a37b1228cc1e0e3ef405342fcb8c027d96bb161d7b205384e179f1de1f45f5e39caafe8282a1811fdde905d5e SHA512 37dfac07238aac007938734fa8d7a3dd3cde3f064d5ab544f21230ad1feb733c4a39fa61a871275848f6dbfeeb66671b2a893e7f7b6a69f13e2fec16f348b77c
+DIST kitty-0.27.0.tar.xz 5067860 BLAKE2B 5c9126dd9e76afcd6d53aa025adc36912145129b16b0db60c9cb12736df895166d417cbce9198e1feddd3f07c216e557136a130853fa0ddd91833c67fe236c4e SHA512 8063008df261747a7089c69ad9ae3a3d3c24286014f02d04faee9f0b5b6f452172cf99ff8a520ca8e314ba0009e0009701292656db913c23d84b6a2311085813
+DIST kitty-0.27.0.tar.xz.sig 566 BLAKE2B d2b39e05e56e10eb3856a4aec105acfa1c3bd289eddab7ff9047e6a9743cf142c5b9b6aa85aa6196e7d6be7a168b475b96e2586ef57f66e29045744ca81c9fa7 SHA512 3f4a70659a17440d0d08d2f909b3279c5043adc981e075d9648892bfa2b7d617bfd520fac8571cd692833082e03b1d9997f9aaa75187318168dfbe6922ec389d
EBUILD kitty-0.26.5-r1.ebuild 3431 BLAKE2B 51eec6dbc5250040fb5c223646586f6114f97eefaa718baab7b3e9c338351467f67a26dd668cf511b18b082d0083ca202a60e8eb7d79a6aaa63ebbe8ba60e821 SHA512 42b24d286efc77299eb984fabf2b4272ced8d9a0a567251ab750b417dfe3584234c04afd8fd19f487d164954915a3ae382fd6bbd4be13d87e5d9544bc5de3920
-EBUILD kitty-9999.ebuild 3970 BLAKE2B 4e28e4ebf9deb0ac2ffe19a04baec6b192d9011ee7e5290aec9aa207c389c8157840fe847b17f954801536210a35f8e27b045c0bb65f77e57f6208a0f0b5f614 SHA512 83044be2f75818e79f760f39927ae73f5c5d0237da39e6116058492345e00b2bca14556e5ba33544ca759afb78da49fd7dff371f689e0643bd481733d5b01c41
+EBUILD kitty-0.27.0.ebuild 4142 BLAKE2B aec7d40ca54e6daf534487897e4fcfff4d325dfa18293bcdaa77b1d54eafd3530cf6c0cd314bd89f3c955ba29a112d05cc846853568e345cac50834ec1201934 SHA512 edc1132f07e0a1d6a005c7e3a68b36b2b7837870092dbd1565088644726ce9a86072dbe6043a221d96f7e85478a791aead0f872e1bd80a51b663e028d86bee62
+EBUILD kitty-9999.ebuild 4142 BLAKE2B aec7d40ca54e6daf534487897e4fcfff4d325dfa18293bcdaa77b1d54eafd3530cf6c0cd314bd89f3c955ba29a112d05cc846853568e345cac50834ec1201934 SHA512 edc1132f07e0a1d6a005c7e3a68b36b2b7837870092dbd1565088644726ce9a86072dbe6043a221d96f7e85478a791aead0f872e1bd80a51b663e028d86bee62
MISC metadata.xml 653 BLAKE2B fd4fd98a8cac30a2e941770c43af4cd475eea1609f35f454780eb4463e052ccb44a1c7f84fe3f1e29eef08041d57d5bc8a688a404d105e7d15691f41cf701f48 SHA512 4c3c390b41e81444a7a22eb78afa92b7a5a15ad8558e92d387da64364bbe0c2fa1088aa9ea7516814280eefc1e7221a7b963a54beeab0213dc2974fcbc2fd003
diff --git a/x11-terms/kitty/kitty-0.27.0.ebuild b/x11-terms/kitty/kitty-0.27.0.ebuild
new file mode 100644
index 000000000000..9d20478938f2
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.27.0.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
+ KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD MIT" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ media-libs/fontconfig
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ net-libs/librsync:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.19
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x GOFLAGS="-buildmode=pie -v -x"
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ [[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
+ rm -r linux-package/share/terminfo || die
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/.
+
+ local execbit
+ mapfile -t execbit < <(find linux-package -type f -perm /+x -printf '/usr/%P\n' || die)
+ fperms +x "${execbit[@]}"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 90f8d00348ee..9d20478938f2 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -13,6 +13,7 @@ else
inherit verify-sig
SRC_URI="
https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
@@ -76,14 +77,16 @@ src_unpack() {
cd "${S}" || die
edo go mod vendor
else
- verify-sig_src_unpack
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
fi
}
src_prepare() {
default
- # sed unfortunately feels easier on maintainenance than patches here
+ # sed unfortunately feels easier on maintenance than patches here
local sedargs=(
-e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
-e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
@@ -100,11 +103,15 @@ src_prepare() {
sed -i setup.py "${sedargs[@]}" || die
- # test relies on 'who' command which doesn't detect users with pid-sandbox
- rm kitty_tests/utmp.py || die
-
- # test may fail/hang depending on environment and shell initialization scripts
- rm kitty_tests/{shell_integration,ssh}.py || die
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
}
src_compile() {
@@ -144,7 +151,6 @@ src_install() {
pkg_postinst() {
xdg_pkg_postinst
- optfeature "in-terminal image display with kitty icat" media-gfx/imagemagick
optfeature "audio-based terminal bell support" media-libs/libcanberra
optfeature "opening links from the terminal" x11-misc/xdg-utils
}