summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/Manifest.gzbin4715 -> 4706 bytes
-rw-r--r--x11-terms/kitty-shell-integration/Manifest2
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild37
-rw-r--r--x11-terms/kitty-terminfo/Manifest2
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild23
-rw-r--r--x11-terms/kitty/Manifest5
-rw-r--r--x11-terms/kitty/kitty-0.26.0.ebuild131
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild16
8 files changed, 207 insertions, 9 deletions
diff --git a/x11-terms/Manifest.gz b/x11-terms/Manifest.gz
index 601fe1c54c64..a6588328eafa 100644
--- a/x11-terms/Manifest.gz
+++ b/x11-terms/Manifest.gz
Binary files differ
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index eb1913486b48..985b3857a4cd 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.25.2.tar.xz 4681940 BLAKE2B 9aa43711c833541f364100465dfd1c13251ed59d5777634a5f193cc0544743295a772de85c64b4657e2cbca3d88f77019b0fe26b25c8b0908c1cc108b480ecf6 SHA512 ac858b525abbdeb137989a7971c51651d46bffedde048ed572bbb4c31119a4e0f9f424edbdbfd14fe2e043b4a7c8a1a1f8ee6591906e40a655d9f783b21f31a6
+DIST kitty-0.26.0.tar.xz 4719488 BLAKE2B 02e06ed8dd6bfdca789efe53211a27855582b2baa845558efd454a9ee8d2d6a71749f8baaad6ac6ba3f5b0878b2786302a26be190dec544488c3918de70ab581 SHA512 e8e041cb8cbe8560e35126d9f717111e0094ef9dd260ade07017f36d8e8e18fd4198cf186198b78089b8a05baa98a512d273b24b7f3f0d4f9f6d06107eb76c58
EBUILD kitty-shell-integration-0.25.2.ebuild 1476 BLAKE2B d07578dfe48ab8aa3ff01b4ed91e0e9e1d357f00d0931d2a4beaa8659c843b130108ce925bb37fdb4679048e1d9bd90a64aaa95150eabb3e6c9b195e504a1bc3 SHA512 0f74797060755fdf9430efbbe5e7d56182b38dafd1d9c8bbf25d01e932e1bc95fb5e774064667b66f8beb8ab1e0772174746506bb9b156b88131dd23a14d82c4
+EBUILD kitty-shell-integration-0.26.0.ebuild 1478 BLAKE2B c9751a6a82bf10a629f06b6099dec2b6d08c0e4d961e6c8105ce7e975e849161bb09a8990a0ed971f96e4ea0787b87e64074d705e807fba6dbef3c3494ea495b SHA512 7f5f6d48619adeb300727cc9b30ef97403a2f6da00a45661cb8cec489ea9ccab02a48ba502d8099175342d832ec9ad98f82aff87bf5ef5d1df50ab7971d8fcea
EBUILD kitty-shell-integration-9999.ebuild 1403 BLAKE2B 9f1e4aebc1103678d42ba5809c41848b2ace36e2ed0137bdb0f30048cb4372c61f80e509a8087a52b149fe25115ca8aaa511d4697459e1087bee65788055dd85 SHA512 d7674435c3d3d9cfd04d47889f9e0f1cb4e60a6dc3506529829b3782e958fc3cb18fe8b0a25463725128106d6ca8308a17ae961b184e13682a1b05852e22ce4e
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild
new file mode 100644
index 000000000000..4c3e987c411b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.26.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+
+ # this is used internally by the ssh kitten and is not useful there
+ rm -r "${ED}"/usr/share/kitty/shell-integration/ssh || die
+}
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 94cbbf0e0946..f9adf0961772 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,4 +1,6 @@
DIST kitty-0.25.2.tar.xz 4681940 BLAKE2B 9aa43711c833541f364100465dfd1c13251ed59d5777634a5f193cc0544743295a772de85c64b4657e2cbca3d88f77019b0fe26b25c8b0908c1cc108b480ecf6 SHA512 ac858b525abbdeb137989a7971c51651d46bffedde048ed572bbb4c31119a4e0f9f424edbdbfd14fe2e043b4a7c8a1a1f8ee6591906e40a655d9f783b21f31a6
+DIST kitty-0.26.0.tar.xz 4719488 BLAKE2B 02e06ed8dd6bfdca789efe53211a27855582b2baa845558efd454a9ee8d2d6a71749f8baaad6ac6ba3f5b0878b2786302a26be190dec544488c3918de70ab581 SHA512 e8e041cb8cbe8560e35126d9f717111e0094ef9dd260ade07017f36d8e8e18fd4198cf186198b78089b8a05baa98a512d273b24b7f3f0d4f9f6d06107eb76c58
EBUILD kitty-terminfo-0.25.2.ebuild 618 BLAKE2B f28c7bc4aff671b8f2df8094f8abd881b9bfe0580fd84e302fea050235f5932c34636e407d87afb34ee1fe2e7006e1dc1a1902d9a914cfe4aa7372fb7d18d368 SHA512 971734b7d326df234fff57c14a17ce6da9e9f97dc86ea412b9521c76e0c06fceadffcb708db781d85d5529a6ec9c829dcd5f8210c36c06b73f6ce05b9be729b3
+EBUILD kitty-terminfo-0.26.0.ebuild 620 BLAKE2B 84d17d934610d200dd4d556462255c9f6ee5fa90553b81db4dc764a9bb4026d74b874f19ef92e3aeaaaf2856021870199518b66e633212896aa5b9d4f5255b8a SHA512 a9dca5ba4c276df302fb5df4507294bdac4609398ed441b242dba8459d2d58306c29a49373278f428c1d86a3e9e426f3605153252aebe9bfac5af00e088fac18
EBUILD kitty-terminfo-9999.ebuild 545 BLAKE2B 50bf783694580b016f3291640d6c4ab3e8ee335f78d13b75cb7ebe6628ddd2f244fab2e7c465a3964ed6b5e0ebbdb144c739a01ffa7239c8518503ea107a52f2 SHA512 267b8b4a526ee22159f7c1c0d9a089e183308e1e7f61d775834e4ed5d4f25be7aac8cc3db4afa3c3f1e933159f27abff25c31989dd6478c1727eec590bf0a3c8
MISC metadata.xml 610 BLAKE2B 29a121e206c4a21965f03cac1b01314dc32384eb617e9c188814f2c9a8896d10cb299aa4ef7fec74c5a74c966069355d291fe23d9f37b2cbb3d34ebb24850f81 SHA512 867c3bfc752f53287bea2f027a949bb433cd069f5480a5197986371db6dac4524577bf1503259a4fb4f6832ec7c860a5f2b4ac495a17c6a19fee5c62a70e6892
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
new file mode 100644
index 000000000000..35ff98034a87
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 0e06843da6b9..386d2a92d0a8 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,6 +1,9 @@
AUX kitty-0.23.1-flags.patch 583 BLAKE2B c95c469d73c67ec90a4c33bb416832bbc7ce4766cf65a9c216cc5afd16f5c71cfccf80e08983d7f0aaea27f29b30ce0746c32065104e8fd1f930be9301751eb3 SHA512 2280cbe367181468bcc2aa8071fcbc6d44e77e65d8261f915b1775ad27f0fd8d48b1387300ba67a2ad0964cb655b66885221785c0ea0f4766c37b827f2987cd0
DIST kitty-0.25.2.tar.xz 4681940 BLAKE2B 9aa43711c833541f364100465dfd1c13251ed59d5777634a5f193cc0544743295a772de85c64b4657e2cbca3d88f77019b0fe26b25c8b0908c1cc108b480ecf6 SHA512 ac858b525abbdeb137989a7971c51651d46bffedde048ed572bbb4c31119a4e0f9f424edbdbfd14fe2e043b4a7c8a1a1f8ee6591906e40a655d9f783b21f31a6
DIST kitty-0.25.2.tar.xz.sig 566 BLAKE2B 38435c7c418b421321ad29e1935f2280b1df215cb95b1025b3c85a0cc7e3279f1a0f79b05af9c698d4121a4f2e23a81774406a3ba77d0b5e669a36e1e58621b6 SHA512 cc16d4d22c043a30d9712cee211b4560873aa3e6ddc799881c791c72c6a4bfb7822a01683c62afcf67814889dfbc312d9f8b1f2200ab7f89a937addbf76c99b9
+DIST kitty-0.26.0.tar.xz 4719488 BLAKE2B 02e06ed8dd6bfdca789efe53211a27855582b2baa845558efd454a9ee8d2d6a71749f8baaad6ac6ba3f5b0878b2786302a26be190dec544488c3918de70ab581 SHA512 e8e041cb8cbe8560e35126d9f717111e0094ef9dd260ade07017f36d8e8e18fd4198cf186198b78089b8a05baa98a512d273b24b7f3f0d4f9f6d06107eb76c58
+DIST kitty-0.26.0.tar.xz.sig 566 BLAKE2B 9f05eb2083ea59f41284dcbf405be46f99fdc910167b522c4d281d8626e59d2e843f82f4526c17d7370e17bf72c3c372e490704702dc851fb3623fae7210db76 SHA512 c9057512767a6a93cd2ba1e621a10a1979aa4788a2fb16e5747df915647efe4a981cc1db772588a8f331d1988bb6f4918cc5e071bcd4dbbe86a7fc228d0856c3
EBUILD kitty-0.25.2.ebuild 3564 BLAKE2B a1399f7f37f98dff758acdb95099abea500b529dff0be0b7a2d37f40b1f3373c4a5b4527a846b89cd194cf01eb52122e3487446066bdcae317f1ae399cfea167 SHA512 b37438a48ae27c198a9e7be0f8d8b3f3735b77329939630122601013d57fea8e9e4d7d821601ca3444bb15526c2afdc7ae0b3aace48a1305d78df7a0a0b4e909
-EBUILD kitty-9999.ebuild 3534 BLAKE2B ab8d87cc0831f3099955d353f8f89974523e5fff0ed3b7aa8f9c4c375f64769696a33f4f3c232d53e4d2cd38f48e4b6f5a9a3594918eca170c6b49fec58ece49 SHA512 b9f4807ae45fb4e43a95434fec45cfb5a6598007c0ec5404fd58fd513e29a313e5ee60c918065ab19dff42d6d46240c11ce9bd3ddd78c237510dfa508f748dcc
+EBUILD kitty-0.26.0.ebuild 3605 BLAKE2B ffb55f025d3b07b00a2c3a4991dfb2f0263dae8f141c24d4d62430e67c22ad09c58f67c23315ae1bd2f1c212ae813ba21e63615f351187a01f7a8c2dce4a2011 SHA512 f85eab66363333c06a7977a99bd282b24183890f9ace2b677c72cb6b3e1a77a2509954d94e077f0ef4797344ea472d94fe2e4fc9770de3d05ded09ea87a340d0
+EBUILD kitty-9999.ebuild 3605 BLAKE2B ffb55f025d3b07b00a2c3a4991dfb2f0263dae8f141c24d4d62430e67c22ad09c58f67c23315ae1bd2f1c212ae813ba21e63615f351187a01f7a8c2dce4a2011 SHA512 f85eab66363333c06a7977a99bd282b24183890f9ace2b677c72cb6b3e1a77a2509954d94e077f0ef4797344ea472d94fe2e4fc9770de3d05ded09ea87a340d0
MISC metadata.xml 757 BLAKE2B 5b7786583ac3a7742c1345fb86287e3309eedf7e7110025730c9153dd893bdbd8e340b3a70f99a650d60f3a405c73346fbb2f0465ba2dad820e9fe2506f9963f SHA512 96c3583ce9713803d9892270f9e41cce2cdb75931065637196c002f66e9638f87db52f32a69d37cc6bef5302cb0cd5212178659b217b1df63e253f4bdf759c77
diff --git a/x11-terms/kitty/kitty-0.26.0.ebuild b/x11-terms/kitty/kitty-0.26.0.ebuild
new file mode 100644
index 000000000000..3ee9cbb30121
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.26.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+X test transfer wayland"
+REQUIRED_USE="
+ || ( X wayland )
+ ${PYTHON_REQUIRED_USE}"
+RESTRICT="!X? ( test ) !test? ( test ) !transfer? ( test ) !wayland? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ media-libs/fontconfig
+ media-libs/harfbuzz:=
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? ( x11-libs/libX11 )
+ transfer? ( net-libs/librsync:= )
+ wayland? ( dev-libs/wayland )"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+src_prepare() {
+ default
+
+ # seds unfortunately feel easier on maintainenance than patches here
+ sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
+ -e "$(usev !X '/gl_libs =/s/=.*/= []/')" \
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/" \
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//' \
+ -i setup.py || die
+
+ if use !transfer; then
+ sed -i 's/rs_cflag =/& []#/;/files.*rsync/d' setup.py || die
+ rm -r kittens/transfer || die
+ fi
+
+ # test relies on 'who' command which doesn't detect users with pid-sandbox
+ rm kitty_tests/utmp.py || die
+
+ # test may fail/hang depending on environment and shell initialization scripts
+ rm kitty_tests/{shell_integration,ssh}.py || die
+
+ # skip docs for live version
+ [[ ${PV} != 9999 ]] || sed -i '/exists.*_build/,/docs(ddir)/d' setup.py || die
+}
+
+src_compile() {
+ tc-export CC
+ export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo ${EPYTHON} setup.py linux-package "${conf[@]}"
+ use test && edo ${EPYTHON} setup.py build-launcher "${conf[@]}"
+
+ [[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
+ rm -r linux-package/share/terminfo || die
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/.
+
+ fperms +x /usr/bin/kitty \
+ /usr/$(get_libdir)/kitty/shell-integration/ssh/{askpass.py,kitty}
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "in-terminal image display with kitty icat" media-gfx/imagemagick
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 92a0509aac27..3ee9cbb30121 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -32,6 +32,7 @@ RESTRICT="!X? ( test ) !test? ( test ) !transfer? ( test ) !wayland? ( test )"
# dlopen: fontconfig,libglvnd
RDEPEND="
${PYTHON_DEPS}
+ dev-libs/openssl:=
media-libs/fontconfig
media-libs/harfbuzz:=
media-libs/lcms:2
@@ -67,9 +68,10 @@ BDEPEND="
src_prepare() {
default
+ # seds unfortunately feel easier on maintainenance than patches here
sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
-e "$(usev !X '/gl_libs =/s/=.*/= []/')" \
- -e "/num_workers = /s/=.*/= $(makeopts_jobs)/" \
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/" \
-e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//' \
-i setup.py || die
@@ -92,8 +94,7 @@ src_compile() {
tc-export CC
export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
- local setup=(
- ${EPYTHON} setup.py linux-package
+ local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings
--libdir-name=$(get_libdir)
@@ -102,16 +103,15 @@ src_compile() {
--verbose
)
- echo "${setup[*]}"
- "${setup[@]}" || die "setup.py failed to compile ${PN}"
+ edo ${EPYTHON} setup.py linux-package "${conf[@]}"
+ use test && edo ${EPYTHON} setup.py build-launcher "${conf[@]}"
[[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
rm -r linux-package/share/terminfo || die
}
src_test() {
- PATH=linux-package/bin:${PATH} KITTY_CONFIG_DIRECTORY=${T} \
- ${EPYTHON} test.py || die
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
}
src_install() {