summaryrefslogtreecommitdiff
path: root/x11-terms/xvt/xvt-2.1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/xvt/xvt-2.1-r3.ebuild')
-rw-r--r--x11-terms/xvt/xvt-2.1-r3.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/x11-terms/xvt/xvt-2.1-r3.ebuild b/x11-terms/xvt/xvt-2.1-r3.ebuild
index 51aaecb83268..ec2d970817df 100644
--- a/x11-terms/xvt/xvt-2.1-r3.ebuild
+++ b/x11-terms/xvt/xvt-2.1-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils flag-o-matic toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A tiny vt100 terminal emulator for X"
HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
@@ -21,27 +21,29 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-1.0
-src_prepare() {
+PATCHES=(
# this brings the distribution upto version 2.1
- epatch "${WORKDIR}"/${P}.diff
+ "${WORKDIR}"/${P}.diff
# fix #61393
- epatch "${FILESDIR}/${PN}-ttyinit-svr4pty.diff"
+ "${FILESDIR}/${PN}-ttyinit-svr4pty.diff"
# CFLAGS, CC #241554
- epatch "${FILESDIR}/${PN}-makefile.patch"
+ "${FILESDIR}/${PN}-makefile.patch"
# int main, not void main
- epatch "${FILESDIR}/${PN}-int-main.patch"
+ "${FILESDIR}/${PN}-int-main.patch"
# fix segfault (bug #363883)
- epatch "${FILESDIR}/${PN}-pts.patch"
+ "${FILESDIR}/${PN}-pts.patch"
+)
+src_configure() {
tc-export CC
}
src_install() {
- dobin xvt || die "dobin failed"
+ dobin xvt
doman xvt.1
- dodoc README
+ einstalldocs
}