summaryrefslogtreecommitdiff
path: root/x11-terms/roxterm/roxterm-3.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/roxterm/roxterm-3.9.3.ebuild')
-rw-r--r--x11-terms/roxterm/roxterm-3.9.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-terms/roxterm/roxterm-3.9.3.ebuild b/x11-terms/roxterm/roxterm-3.9.3.ebuild
new file mode 100644
index 000000000000..af6a540bc9c5
--- /dev/null
+++ b/x11-terms/roxterm/roxterm-3.9.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A terminal emulator designed to integrate with the ROX environment"
+HOMEPAGE="https://github.com/realh/roxterm"
+SRC_URI="https://github.com/realh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/dbus-glib
+ dev-libs/glib:2
+ dev-libs/libpcre2
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ x11-libs/vte:2.91[vanilla]"
+# vanilla vte due to https://github.com/realh/roxterm/issues/222
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}