summaryrefslogtreecommitdiff
path: root/x11-terms/qterminal/qterminal-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-9999.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/x11-terms/qterminal/qterminal-9999.ebuild b/x11-terms/qterminal/qterminal-9999.ebuild
index 90a2ee44c5eb..2c670eef48ff 100644
--- a/x11-terms/qterminal/qterminal-9999.ebuild
+++ b/x11-terms/qterminal/qterminal-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,20 +6,20 @@ EAPI=7
inherit cmake xdg-utils
DESCRIPTION="Qt-based multitab terminal emulator"
-HOMEPAGE="https://lxqt.org/"
+HOMEPAGE="https://lxqt.github.io/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
- SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
-LICENSE="GPL-2"
+LICENSE="GPL-2 GPL-2+"
SLOT="0"
-BDEPEND=">=dev-util/lxqt-build-tools-0.6.0"
+BDEPEND=">=dev-util/lxqt-build-tools-0.7.0"
DEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -29,7 +29,9 @@ DEPEND="
x11-libs/libX11
~x11-libs/qtermwidget-${PV}
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
pkg_postinst() {
xdg_icon_cache_update