summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/kitty-0.34.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty/kitty-0.34.1.ebuild')
-rw-r--r--x11-terms/kitty/kitty-0.34.1.ebuild14
1 files changed, 2 insertions, 12 deletions
diff --git a/x11-terms/kitty/kitty-0.34.1.ebuild b/x11-terms/kitty/kitty-0.34.1.ebuild
index f9154e4c3581..cdd3efe60acc 100644
--- a/x11-terms/kitty/kitty-0.34.1.ebuild
+++ b/x11-terms/kitty/kitty-0.34.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit edo flag-o-matic go-env optfeature multiprocessing
+inherit edo go-env optfeature multiprocessing
inherit python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]]; then
@@ -18,7 +18,7 @@ else
verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
"
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
- KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
fi
DESCRIPTION="Fast, feature-rich, GPU-based terminal"
@@ -136,16 +136,6 @@ src_compile() {
local -x GOFLAGS="-p=$(makeopts_jobs) -v -x -buildvcs=false"
use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
- # workaround link errors with Go + gcc + -g3 (bug #924436),
- # retry now and then to see if can be dropped
- tc-is-gcc &&
- CGO_CFLAGS=$(
- CFLAGS=${CGO_CFLAGS}
- replace-flags -g3 -g
- replace-flags -ggdb3 -ggdb
- printf %s "${CFLAGS}"
- )
-
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings